summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-10-16 09:33:50 +0800
committerzxp198210052023-10-16 09:33:50 +0800
commit5b59b65e0bc530299b2be80d525c06d934b2fc0f (patch)
treef5a7c3b6ee25f5edabbef8ffeccb89852dca5f65
parent1b53221b3f375f29e73391e782223d0e4c405d75 (diff)
downloadaur-5b59b65e0bc530299b2be80d525c06d934b2fc0f.tar.gz
update to 0.18.15
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD8
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b8eb7e3e73ca..86df6ab7be3a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lvce-bin
pkgdesc = VS Code inspired text editor that mostly runs in a webworker
- pkgver = 0.18.13
+ pkgver = 0.18.15
pkgrel = 1
url = https://lvce-editor.github.io/lvce-editor
arch = aarch64
@@ -31,14 +31,14 @@ pkgbase = lvce-bin
depends = libxkbcommon
depends = libxcb
depends = cairo
- provides = lvce=0.18.13
+ provides = lvce=0.18.15
conflicts = lvce
options = !strip
- source_aarch64 = lvce-0.18.13-aarch64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.18.13/lvce-v0.18.13_arm64.deb
- sha256sums_aarch64 = 5428ea252d9368665c9f05011be957b510f40b24a7d4caa8541f2ac728038638
- source_armv7h = lvce-0.18.13-armv7h.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.18.13/lvce-v0.18.13_armhf.deb
- sha256sums_armv7h = 1149de05b165f6c08cef7fa24e24d34c4b5137e59c50e11c0c09299858d790a2
- source_x86_64 = lvce-0.18.13-x86_64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.18.13/lvce-v0.18.13_amd64.deb
- sha256sums_x86_64 = 57178b134f03e918c420a291d9d2d123defe164e3521b08e347d26fe4c1211c3
+ source_aarch64 = lvce-0.18.15-aarch64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.18.15/lvce-v0.18.15_arm64.deb
+ sha256sums_aarch64 = 3f89a46420e946e9e8364ee3ed4f8ae422aa4edee2b7381d497c9e397e226a7c
+ source_armv7h = lvce-0.18.15-armv7h.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.18.15/lvce-v0.18.15_armhf.deb
+ sha256sums_armv7h = 69a1ece123711c8be9afb788f6d57653506498308a9d5ed5ade87057b5882493
+ source_x86_64 = lvce-0.18.15-x86_64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.18.15/lvce-v0.18.15_amd64.deb
+ sha256sums_x86_64 = 03c77708087c9a5cc2491903d5302b31350997ccdeae27a3cbc57cd934563e5b
pkgname = lvce-bin
diff --git a/PKGBUILD b/PKGBUILD
index 8b9307f4dad4..d72e5d9ada14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=lvce-bin
-pkgver=0.18.13
+pkgver=0.18.15
pkgrel=1
pkgdesc="VS Code inspired text editor that mostly runs in a webworker"
arch=('aarch64' 'armv7h' 'x86_64')
@@ -15,9 +15,9 @@ depends=('libxrandr' 'expat' 'libx11' 'dbus' 'nss' 'libxfixes' 'gcc-libs' 'alsa-
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.deb::${_githuburl}/releases/download/v${pkgver}/${pkgname%-bin}-v${pkgver}_arm64.deb")
source_armv7h=("${pkgname%-bin}-${pkgver}-armv7h.deb::${_githuburl}/releases/download/v${pkgver}/${pkgname%-bin}-v${pkgver}_armhf.deb")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.deb::${_githuburl}/releases/download/v${pkgver}/${pkgname%-bin}-v${pkgver}_amd64.deb")
-sha256sums_aarch64=('5428ea252d9368665c9f05011be957b510f40b24a7d4caa8541f2ac728038638')
-sha256sums_armv7h=('1149de05b165f6c08cef7fa24e24d34c4b5137e59c50e11c0c09299858d790a2')
-sha256sums_x86_64=('57178b134f03e918c420a291d9d2d123defe164e3521b08e347d26fe4c1211c3')
+sha256sums_aarch64=('3f89a46420e946e9e8364ee3ed4f8ae422aa4edee2b7381d497c9e397e226a7c')
+sha256sums_armv7h=('69a1ece123711c8be9afb788f6d57653506498308a9d5ed5ade87057b5882493')
+sha256sums_x86_64=('03c77708087c9a5cc2491903d5302b31350997ccdeae27a3cbc57cd934563e5b')
build() {
bsdtar -xf "${srcdir}/data.tar.xz"
sed "s| %U| --no-sandbox %U|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"