summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-18 12:05:09 +0800
committerzxp198210052024-03-18 12:05:09 +0800
commit7542b4074309dc8851745cfd2b11099a14fff249 (patch)
treea4ef8fdeda1e702b9c1c769f262fb430aa084038
parent6b0183388d6b9e7922bc33d3e65d6370be790b4d (diff)
downloadaur-7542b4074309dc8851745cfd2b11099a14fff249.tar.gz
update to 0.24.3
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD13
-rw-r--r--lvce.sh8
3 files changed, 22 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 472b6c0087b8..420f5fd5acf2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lvce-bin
pkgdesc = VS Code inspired text editor that mostly runs in a webworker
- pkgver = 0.24.2
+ pkgver = 0.24.3
pkgrel = 1
url = https://lvce-editor.github.io/lvce-editor
arch = aarch64
@@ -9,18 +9,18 @@ pkgbase = lvce-bin
license = MIT
depends = electron28
depends = nodejs
- provides = lvce=0.24.2
+ provides = lvce=0.24.3
conflicts = lvce
options = !strip
source = lintian-lvce
source = lvce.sh
sha256sums = ada1a0303abece27be80372538645da5c5b4e9d60fcacc87b97da1c26b8931bc
- sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
- source_aarch64 = lvce-0.24.2-aarch64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.24.2/lvce-v0.24.2_arm64.deb
- sha256sums_aarch64 = 26cf3cae9822a0fbfa53935c8836adf2f9707418dd9e7f13d8d0e3edd5b76f04
- source_armv7h = lvce-0.24.2-armv7h.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.24.2/lvce-v0.24.2_armhf.deb
- sha256sums_armv7h = 21baf5d778f0e2d9436e7b425552dd41f4413d089ec4c73decabc978e1780def
- source_x86_64 = lvce-0.24.2-x86_64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.24.2/lvce-v0.24.2_amd64.deb
- sha256sums_x86_64 = a3ead0e797179456338b66881ed6cd1b93e5a0acf1108bb7f87513ebf5a278cc
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
+ source_aarch64 = lvce-0.24.3-aarch64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.24.3/lvce-v0.24.3_arm64.deb
+ sha256sums_aarch64 = 22c405564e3ffb819c09478487b9d03d2a42a8bd9e94799b40c6f3b6182ea7ce
+ source_armv7h = lvce-0.24.3-armv7h.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.24.3/lvce-v0.24.3_armhf.deb
+ sha256sums_armv7h = 0b6829d75c8d3fda33d0f1c4be5e8b8f30272d3e7664d6545520eaf62fc29ff4
+ source_x86_64 = lvce-0.24.3-x86_64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.24.3/lvce-v0.24.3_amd64.deb
+ sha256sums_x86_64 = ab48dde2119645ffda435d62a173f0ca414205f093e7c4479dc1be9604002bdd
pkgname = lvce-bin
diff --git a/PKGBUILD b/PKGBUILD
index 9c8fb833469c..8a08218de617 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=lvce-bin
-pkgver=0.24.2
+pkgver=0.24.3
_electronversion=28
pkgrel=1
pkgdesc="VS Code inspired text editor that mostly runs in a webworker"
@@ -27,10 +27,10 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('ada1a0303abece27be80372538645da5c5b4e9d60fcacc87b97da1c26b8931bc'
- '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
-sha256sums_aarch64=('26cf3cae9822a0fbfa53935c8836adf2f9707418dd9e7f13d8d0e3edd5b76f04')
-sha256sums_armv7h=('21baf5d778f0e2d9436e7b425552dd41f4413d089ec4c73decabc978e1780def')
-sha256sums_x86_64=('a3ead0e797179456338b66881ed6cd1b93e5a0acf1108bb7f87513ebf5a278cc')
+ 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
+sha256sums_aarch64=('22c405564e3ffb819c09478487b9d03d2a42a8bd9e94799b40c6f3b6182ea7ce')
+sha256sums_armv7h=('0b6829d75c8d3fda33d0f1c4be5e8b8f30272d3e7664d6545520eaf62fc29ff4')
+sha256sums_x86_64=('ab48dde2119645ffda435d62a173f0ca414205f093e7c4479dc1be9604002bdd')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
@@ -38,8 +38,11 @@ build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data."*
+ sed "s|/usr/lib/${pkgname%-bin}/${pkgname%-bin}|${pkgname%-bin}|g" -i \
+ "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
diff --git a/lvce.sh b/lvce.sh
index f9ced1432cfc..7ddcaab8d734 100644
--- a/lvce.sh
+++ b/lvce.sh
@@ -1,14 +1,16 @@
-#!/bin/sh
+#!/bin/bash
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file