summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-04-02 11:06:08 +0800
committerzxp198210052024-04-02 11:06:08 +0800
commit7c417029b1065321dac26781db17ea03e87217ad (patch)
tree30f72923c7d8c9bf9aa8650cc501267a6c3f3a22
parent2a0fd5dd901ac42176dae3e38527db92c00b71b8 (diff)
downloadaur-7c417029b1065321dac26781db17ea03e87217ad.tar.gz
update to 0.25.2
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD20
2 files changed, 21 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5410c27543ca..0be5347498cc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,26 @@
pkgbase = lvce-bin
pkgdesc = VS Code inspired text editor that mostly runs in a webworker
- pkgver = 0.25.1
+ pkgver = 0.25.2
pkgrel = 1
url = https://lvce-editor.github.io/lvce-editor
arch = aarch64
arch = armv7h
arch = x86_64
license = MIT
- depends = electron28
+ depends = electron
depends = nodejs
- provides = lvce=0.25.1
+ provides = lvce=0.25.2
conflicts = lvce
options = !strip
source = lintian-lvce
source = lvce.sh
sha256sums = ada1a0303abece27be80372538645da5c5b4e9d60fcacc87b97da1c26b8931bc
sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
- source_aarch64 = lvce-0.25.1-aarch64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.25.1/lvce-v0.25.1_arm64.deb
- sha256sums_aarch64 = 348d02c6a118686eaec677f400326fa8be12971ea98d045acef55fdddebed6d3
- source_armv7h = lvce-0.25.1-armv7h.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.25.1/lvce-v0.25.1_armhf.deb
- sha256sums_armv7h = 20fe0c4fc7d8d2abc6af26994dbff1798e49164689f6e96df4035fd49773d5e5
- source_x86_64 = lvce-0.25.1-x86_64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.25.1/lvce-v0.25.1_amd64.deb
- sha256sums_x86_64 = c91fc685e790e00e887c252eb615974c22263b00af28954a74dacc050080529b
+ source_aarch64 = lvce-0.25.2-aarch64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.25.2/lvce-v0.25.2_arm64.deb
+ sha256sums_aarch64 = e8009d6c2b3db043896c236a3b3556b38ada29d6555ed17f4643068162491f64
+ source_armv7h = lvce-0.25.2-armv7h.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.25.2/lvce-v0.25.2_armhf.deb
+ sha256sums_armv7h = d69c8c1a9ad646857e227c8901da0d9bedd4eaeda7c371cf481291f8a1aae00e
+ source_x86_64 = lvce-0.25.2-x86_64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.25.2/lvce-v0.25.2_amd64.deb
+ sha256sums_x86_64 = 32db518ed65a0c53b34806f2f3a34548ceeee2bb8f2fc7424ade172a64124485
pkgname = lvce-bin
diff --git a/PKGBUILD b/PKGBUILD
index 5e544e17ed4b..a83a6e4d0bff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,6 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=lvce-bin
-pkgver=0.25.1
-_electronversion=28
+pkgver=0.25.2
pkgrel=1
pkgdesc="VS Code inspired text editor that mostly runs in a webworker"
arch=(
@@ -28,19 +27,24 @@ source=(
)
sha256sums=('ada1a0303abece27be80372538645da5c5b4e9d60fcacc87b97da1c26b8931bc'
'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
-sha256sums_aarch64=('348d02c6a118686eaec677f400326fa8be12971ea98d045acef55fdddebed6d3')
-sha256sums_armv7h=('20fe0c4fc7d8d2abc6af26994dbff1798e49164689f6e96df4035fd49773d5e5')
-sha256sums_x86_64=('c91fc685e790e00e887c252eb615974c22263b00af28954a74dacc050080529b')
+sha256sums_aarch64=('e8009d6c2b3db043896c236a3b3556b38ada29d6555ed17f4643068162491f64')
+sha256sums_armv7h=('d69c8c1a9ad646857e227c8901da0d9bedd4eaeda7c371cf481291f8a1aae00e')
+sha256sums_x86_64=('32db518ed65a0c53b34806f2f3a34548ceeee2bb8f2fc7424ade172a64124485')
+prepare() {
+ bsdtar -xf "${srcdir}/data."*
+}
+_electronversion() {
+ strings "${srcdir}/usr/lib/${pkgname%-bin}/${pkgname%-bin}" | grep '^Chrome/[0-9.]* Electron/[0-9]' | awk '{print $2}' | sed 's|Electron\/||g;s|\.| |g' | awk '{print $1}'
+}
build() {
- sed -e "s|@electronversion@|${_electronversion}|" \
+ sed -e "s|@electronversion@|$(_electronversion)|" \
-e "s|@appname@|${pkgname%-bin}|g" \
-i "${srcdir}/lintian-${pkgname%-bin}"
- sed -e "s|@electronversion@|${_electronversion}|" \
+ sed -e "s|@electronversion@|$(_electronversion)|" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app|g" \
-e "s|@options@|env ELECTRON_OZONE_PLATFORM_HINT=auto|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
- bsdtar -xf "${srcdir}/data."*
sed "s|/usr/lib/${pkgname%-bin}/${pkgname%-bin}|${pkgname%-bin}|g" -i \
"${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}