summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-12-13 10:06:26 +0800
committerzxp198210052023-12-13 10:06:26 +0800
commit908c640ab360573b90ca12d8a51a05bb61005e58 (patch)
treedf56f2338c2e928a98c9467f95c20ccec267c355
parent21c092c6f9db5c2dcfccd5e8e8e5288112f00648 (diff)
downloadaur-908c640ab360573b90ca12d8a51a05bb61005e58.tar.gz
update to 0.21.1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD10
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d90fb2f5d7e2..c819a1ce9fa5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lvce-bin
pkgdesc = VS Code inspired text editor that mostly runs in a webworker
- pkgver = 0.20.15
+ pkgver = 0.21.1
pkgrel = 1
url = https://lvce-editor.github.io/lvce-editor
arch = aarch64
@@ -8,15 +8,15 @@ pkgbase = lvce-bin
arch = x86_64
license = MIT
depends = electron28
- provides = lvce=0.20.15
+ provides = lvce=0.21.1
conflicts = lvce
source = lvce.sh
sha256sums = 8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84
- source_aarch64 = lvce-0.20.15-aarch64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.20.15/lvce-v0.20.15_arm64.deb
- sha256sums_aarch64 = f8915765a37f90c6641df3f1fd6953a9c2c261d5fd37f271f11231ec00cbe039
- source_armv7h = lvce-0.20.15-armv7h.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.20.15/lvce-v0.20.15_armhf.deb
- sha256sums_armv7h = 7df74adf1e46dc73ef5b0c7b9b2d94a762f2427ff57cbdc3243dc0bd8f872a63
- source_x86_64 = lvce-0.20.15-x86_64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.20.15/lvce-v0.20.15_amd64.deb
- sha256sums_x86_64 = 2a099550055f9ba1fdca14b36b2f2fb9920f4612285e245f65de957a59e51ff1
+ source_aarch64 = lvce-0.21.1-aarch64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.21.1/lvce-v0.21.1_arm64.deb
+ sha256sums_aarch64 = c74972b5e74f30230837c4eef5d4c597f6f60a2e5757ac21d3ce571d0c29b0fa
+ source_armv7h = lvce-0.21.1-armv7h.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.21.1/lvce-v0.21.1_armhf.deb
+ sha256sums_armv7h = f57c656c0a6b0101c1032114564206d53d035bb20ded3fa1cc7b64c8f1d29e99
+ source_x86_64 = lvce-0.21.1-x86_64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.21.1/lvce-v0.21.1_amd64.deb
+ sha256sums_x86_64 = c833374b02b740ff681532860042b7a396e0d176fb5dd3474ef07b47d056c781
pkgname = lvce-bin
diff --git a/PKGBUILD b/PKGBUILD
index 12b603c55162..8c4f293eb0b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=lvce-bin
-pkgver=0.20.15
+pkgver=0.21.1
_electronversion=28
pkgrel=1
pkgdesc="VS Code inspired text editor that mostly runs in a webworker"
@@ -22,9 +22,9 @@ source_armv7h=("${pkgname%-bin}-${pkgver}-armv7h.deb::${_ghurl}/releases/downloa
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}-v${pkgver}_amd64.deb")
source=("${pkgname%-bin}.sh")
sha256sums=('8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84')
-sha256sums_aarch64=('f8915765a37f90c6641df3f1fd6953a9c2c261d5fd37f271f11231ec00cbe039')
-sha256sums_armv7h=('7df74adf1e46dc73ef5b0c7b9b2d94a762f2427ff57cbdc3243dc0bd8f872a63')
-sha256sums_x86_64=('2a099550055f9ba1fdca14b36b2f2fb9920f4612285e245f65de957a59e51ff1')
+sha256sums_aarch64=('c74972b5e74f30230837c4eef5d4c597f6f60a2e5757ac21d3ce571d0c29b0fa')
+sha256sums_armv7h=('f57c656c0a6b0101c1032114564206d53d035bb20ded3fa1cc7b64c8f1d29e99')
+sha256sums_x86_64=('c833374b02b740ff681532860042b7a396e0d176fb5dd3474ef07b47d056c781')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
@@ -41,4 +41,4 @@ package() {
install -Dm644 "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
install -Dm644 "${srcdir}/usr/share/pixmaps/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
install -Dm644 "${srcdir}/usr/share/bash-completion/completions/${pkgname%-bin}" -t "${pkgdir}/usr/share/bash-completion/completions"
-}
+} \ No newline at end of file