summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-22 06:24:45 +0800
committerzxp198210052024-02-22 06:24:45 +0800
commitc6e006282d951e09d70fd17e2ab978c6cc783e19 (patch)
tree2e744b20441fba47ed5ae4bd133a3f66685bd9f0
parent516b881cd983e226667f019867961df292e359d6 (diff)
downloadaur-c6e006282d951e09d70fd17e2ab978c6cc783e19.tar.gz
update to 0.23.3
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD10
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e1b2e3c2f616..364d07b93e20 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lvce-bin
pkgdesc = VS Code inspired text editor that mostly runs in a webworker
- pkgver = 0.23.2
+ pkgver = 0.23.3
pkgrel = 1
url = https://lvce-editor.github.io/lvce-editor
arch = aarch64
@@ -9,18 +9,18 @@ pkgbase = lvce-bin
license = MIT
depends = electron28
depends = nodejs
- provides = lvce=0.23.2
+ provides = lvce=0.23.3
conflicts = lvce
options = !strip
source = lintian-lvce
source = lvce.sh
sha256sums = ada1a0303abece27be80372538645da5c5b4e9d60fcacc87b97da1c26b8931bc
sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
- source_aarch64 = lvce-0.23.2-aarch64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.23.2/lvce-v0.23.2_arm64.deb
- sha256sums_aarch64 = f01569e57a618255a9619849ae408310f661fc2135025f82d11d6f5e9132885d
- source_armv7h = lvce-0.23.2-armv7h.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.23.2/lvce-v0.23.2_armhf.deb
- sha256sums_armv7h = 589910e5194b899c533e399a7334863e254103609e0d9f7c6b10a8725b3fb2da
- source_x86_64 = lvce-0.23.2-x86_64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.23.2/lvce-v0.23.2_amd64.deb
- sha256sums_x86_64 = e5d9256a66238a4c4f3cd24161ba225990e52ced6be11cdcc71995fb03e7ccfa
+ source_aarch64 = lvce-0.23.3-aarch64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.23.3/lvce-v0.23.3_arm64.deb
+ sha256sums_aarch64 = 6443a6ea8fcd93f7d68b44dbf52a420b4604d0f4c0819c2d1ef42d9f77f3136b
+ source_armv7h = lvce-0.23.3-armv7h.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.23.3/lvce-v0.23.3_armhf.deb
+ sha256sums_armv7h = 4f3b8a6248d9799053a84184cf8bdb60dd90c23d73d065206bba1f02816edf21
+ source_x86_64 = lvce-0.23.3-x86_64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.23.3/lvce-v0.23.3_amd64.deb
+ sha256sums_x86_64 = fd14075eb6486ec0256fabe203dd776d9d84382c97b3cd8d52f4b13236762017
pkgname = lvce-bin
diff --git a/PKGBUILD b/PKGBUILD
index 9a9822e94b00..8e37bf01cb7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=lvce-bin
-pkgver=0.23.2
+pkgver=0.23.3
_electronversion=28
pkgrel=1
pkgdesc="VS Code inspired text editor that mostly runs in a webworker"
@@ -28,9 +28,9 @@ source=(
)
sha256sums=('ada1a0303abece27be80372538645da5c5b4e9d60fcacc87b97da1c26b8931bc'
'0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
-sha256sums_aarch64=('f01569e57a618255a9619849ae408310f661fc2135025f82d11d6f5e9132885d')
-sha256sums_armv7h=('589910e5194b899c533e399a7334863e254103609e0d9f7c6b10a8725b3fb2da')
-sha256sums_x86_64=('e5d9256a66238a4c4f3cd24161ba225990e52ced6be11cdcc71995fb03e7ccfa')
+sha256sums_aarch64=('6443a6ea8fcd93f7d68b44dbf52a420b4604d0f4c0819c2d1ef42d9f77f3136b')
+sha256sums_armv7h=('4f3b8a6248d9799053a84184cf8bdb60dd90c23d73d065206bba1f02816edf21')
+sha256sums_x86_64=('fd14075eb6486ec0256fabe203dd776d9d84382c97b3cd8d52f4b13236762017')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
@@ -39,7 +39,7 @@ build() {
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
- bsdtar -xf "${srcdir}/data.tar.xz"
+ bsdtar -xf "${srcdir}/data."*
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"