summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-12-11 10:15:29 +0800
committerzxp198210052023-12-11 10:15:29 +0800
commite11b9ebbbe77e5f7b8204ae0dfd42bb4dcb9b5f4 (patch)
tree09338bf39e397ef7a18057de0821825006771c64
parent1bfecd4d0a850f169d96ca7ba2e9dc628a2c6f21 (diff)
downloadaur-e11b9ebbbe77e5f7b8204ae0dfd42bb4dcb9b5f4.tar.gz
update to 0.20.15
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD8
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 946f79b3e5fa..d90fb2f5d7e2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lvce-bin
pkgdesc = VS Code inspired text editor that mostly runs in a webworker
- pkgver = 0.20.13
+ pkgver = 0.20.15
pkgrel = 1
url = https://lvce-editor.github.io/lvce-editor
arch = aarch64
@@ -8,15 +8,15 @@ pkgbase = lvce-bin
arch = x86_64
license = MIT
depends = electron28
- provides = lvce=0.20.13
+ provides = lvce=0.20.15
conflicts = lvce
source = lvce.sh
sha256sums = 8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84
- source_aarch64 = lvce-0.20.13-aarch64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.20.13/lvce-v0.20.13_arm64.deb
- sha256sums_aarch64 = 02324f412a03c9cd11519cb41866fd30389d3f1e10a90632092f4aa5a471f11e
- source_armv7h = lvce-0.20.13-armv7h.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.20.13/lvce-v0.20.13_armhf.deb
- sha256sums_armv7h = 5f23523aaec971f9c1cf0f843b1f83e0402cc056e034f6a5ffc54ca9fcdc84d1
- source_x86_64 = lvce-0.20.13-x86_64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.20.13/lvce-v0.20.13_amd64.deb
- sha256sums_x86_64 = 315b116df2f2184acc89db1b7621882aeb81056151e044f875942a4a8225e13c
+ source_aarch64 = lvce-0.20.15-aarch64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.20.15/lvce-v0.20.15_arm64.deb
+ sha256sums_aarch64 = f8915765a37f90c6641df3f1fd6953a9c2c261d5fd37f271f11231ec00cbe039
+ source_armv7h = lvce-0.20.15-armv7h.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.20.15/lvce-v0.20.15_armhf.deb
+ sha256sums_armv7h = 7df74adf1e46dc73ef5b0c7b9b2d94a762f2427ff57cbdc3243dc0bd8f872a63
+ source_x86_64 = lvce-0.20.15-x86_64.deb::https://github.com/lvce-editor/lvce-editor/releases/download/v0.20.15/lvce-v0.20.15_amd64.deb
+ sha256sums_x86_64 = 2a099550055f9ba1fdca14b36b2f2fb9920f4612285e245f65de957a59e51ff1
pkgname = lvce-bin
diff --git a/PKGBUILD b/PKGBUILD
index 7f30e379833d..6962f4aa076d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=lvce-bin
-pkgver=0.20.13
+pkgver=0.20.15
_electronversion=28
pkgrel=1
pkgdesc="VS Code inspired text editor that mostly runs in a webworker"
@@ -22,9 +22,9 @@ source_armv7h=("${pkgname%-bin}-${pkgver}-armv7h.deb::${_ghurl}/releases/downloa
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}-v${pkgver}_amd64.deb")
source=("${pkgname%-bin}.sh")
sha256sums=('8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84')
-sha256sums_aarch64=('02324f412a03c9cd11519cb41866fd30389d3f1e10a90632092f4aa5a471f11e')
-sha256sums_armv7h=('5f23523aaec971f9c1cf0f843b1f83e0402cc056e034f6a5ffc54ca9fcdc84d1')
-sha256sums_x86_64=('315b116df2f2184acc89db1b7621882aeb81056151e044f875942a4a8225e13c')
+sha256sums_aarch64=('f8915765a37f90c6641df3f1fd6953a9c2c261d5fd37f271f11231ec00cbe039')
+sha256sums_armv7h=('7df74adf1e46dc73ef5b0c7b9b2d94a762f2427ff57cbdc3243dc0bd8f872a63')
+sha256sums_x86_64=('2a099550055f9ba1fdca14b36b2f2fb9920f4612285e245f65de957a59e51ff1')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \