summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Runge2021-12-29 13:17:02 +0000
committerDavid Runge2021-12-29 13:17:02 +0000
commit57e88457804e2c31cd420674ef6f9479eb8fc3bd (patch)
treef2510e565a67414d72baf17c061f0afe596d7bba
parent1c367aadbd21b4bd3628c49dbe96a0e63a55c77f (diff)
downloadaur-57e88457804e2c31cd420674ef6f9479eb8fc3bd.tar.gz
Rebuild to fix issues with LTO.
Add -ffat-lto-objects to CXXFLAGS to prevent mangled static libs. Add export of LINKFLAGS to prevent waf from overlinking. Simplify quoting in file.
-rw-r--r--PKGBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2758584aecd6..8358f873f2fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
# Maintainer: David Runge <dvzrv@archlinux.org>
+
pkgname=lvtk
pkgver=1.2.0
-pkgrel=2
+pkgrel=3
pkgdesc="Libraries wrapping the LV2 C API and extensions into C++ classes"
-arch=('x86_64')
+arch=(x86_64)
url="https://github.com/lvtk/lvtk"
-license=('GPL3')
-depends=('gcc-libs' 'glibc')
-makedepends=('boost' 'gtkmm' 'lv2' 'waf')
+license=(GPL3)
+depends=(gcc-libs glibc)
+makedepends=(boost gtkmm lv2 waf)
optdepends=('atk: for example plugins'
'atkmm: for example plugins'
'cairo: for example plugins'
@@ -23,6 +24,7 @@ optdepends=('atk: for example plugins'
'pangomm: for example plugins')
source=("$pkgname-$pkgver.tar.gz::https://github.com/${pkgname}/${pkgname}/archive/${pkgver}.tar.gz")
sha512sums=('f193ec28103cb2f6353ff0f96f8790041baf1ae99472c5d04017c23b42d0179b1f5e1de6722e17080410311d0e7e1de4ca0ae9ab76fb3bf8a02d9dc1451d8db7')
+b2sums=('d6aa47f5d89e861393b95d60fe53a232f8047c77f8593dc7dcfc700c3933d2bc37e3e499d1d63a84854e0bcfc2232c170cc92b69fd8b01be30f0f581b216a4a9')
prepare() {
cd "$pkgname-$pkgver"
@@ -31,17 +33,18 @@ prepare() {
}
build() {
+ export LINKFLAGS="$LDFLAGS"
+ CXXFLAGS+=" -std=c++11 -ffat-lto-objects"
+
cd "$pkgname-$pkgver"
- export CXXFLAGS="-std=c++11 $CXXFLAGS"
waf configure --prefix=/usr \
- --boost-includes='/usr/include/boost' \
- --boost-libs='/usr/lib'
+ --boost-includes=/usr/include/boost \
+ --boost-libs=/usr/lib
waf build
}
package() {
cd "$pkgname-$pkgver"
waf install --destdir="$pkgdir/"
- install -vDm 644 {AUTHORS,ChangeLog,README} \
- -t "${pkgdir}/usr/share/doc/${pkgname}/"
+ install -vDm 644 {AUTHORS,ChangeLog,README} -t "${pkgdir}/usr/share/doc/${pkgname}/"
}