summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederik "Freso" S. Olesen2011-10-14 22:43:17 +0200
committerFrederik "Freso" S. Olesen2011-10-14 22:43:17 +0200
commitfe6e649de3123c281817fbd5e4cd068df2c72fa4 (patch)
treec4336cf8b9b0d6615e447b8cd20630542b514a3e
parent626ed4fb3e341dee1e7c08156d591a6473798f97 (diff)
downloadaur-fe6e649de3123c281817fbd5e4cd068df2c72fa4.tar.gz
lwjgl: Added PKGBUILD for lwjgl.
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore2
-rw-r--r--ChangeLog9
-rw-r--r--PKGBUILD39
4 files changed, 41 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f952ca86d69..9e21376728dc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = lwjgl
- pkgdesc = The Lightweight Java Game Library. Binary install.
+ pkgdesc = Lightweight Java Game Library - for use in game projects in Java.
pkgver = 2.8.0
pkgrel = 1
- url = http://lwjgl.org
- arch = i686
- arch = x86_64
+ url = http://lwjgl.org/
+ changelog = ChangeLog
+ arch = any
license = BSD
- makedepends = unzip
- depends = java-runtime>=6
- depends = openal
- source = http://downloads.sourceforge.net/project/java-game-lib/Official%20Releases/LWJGL%202.8.0/lwjgl-2.8.0.zip
+ source = http://downloads.sourceforge.net/java-game-lib/lwjgl-2.8.0.zip
md5sums = 9e701c32a5301f61468a7a41574edaec
+ sha1sums = 7705aa87f93fe07233f32f7573c4681e6c497aa6
pkgname = lwjgl
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f168b49cd4b5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+# source files
+lwjgl-*.zip
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..beb7c3b170e7
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,9 @@
+2011-10-14 Frederik "Freso" S. Olesen <freso.dk@gmail.com>
+
+ * lwjgl-2.8.0 :
+ First PKGBUILD for the library.
+ The reason we install it all in /usr/share/ and not in Java's library path, is
+ that this is not recommended by the LWJGL developers. The libraries should
+ rather be included in the development project it self. See
+ http://lwjgl.org/wiki/index.php?title=Downloading_and_Setting_Up_LWJGL
+ for additional information
diff --git a/PKGBUILD b/PKGBUILD
index 7903b072234a..4e2c73125a91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,32 @@
+# Maintainer: Frederik "Freso" S. Olesen <freso.dk@gmail.com>
pkgname=lwjgl
pkgver=2.8.0
pkgrel=1
-pkgdesc="The Lightweight Java Game Library. Binary install."
-arch=(i686 x86_64)
-url="http://lwjgl.org"
+pkgdesc="Lightweight Java Game Library - for use in game projects in Java."
+arch=(any)
+url="http://lwjgl.org/"
license=('BSD')
-source=(http://downloads.sourceforge.net/project/java-game-lib/Official%20Releases/LWJGL%20$pkgver/$pkgname-$pkgver.zip)
-depends=('java-runtime>=6' 'openal')
-makedepends=('unzip')
+changelog=ChangeLog
+source=(http://downloads.sourceforge.net/java-game-lib/$pkgname-$pkgver.zip)
md5sums=('9e701c32a5301f61468a7a41574edaec')
+sha1sums=('7705aa87f93fe07233f32f7573c4681e6c497aa6')
-build() {
- cd $srcdir/$pkgname-$pkgver
- #unzip -q $pkgname-$pkgver.zip
- #cd $pkgname-$pkgver
- install -d $pkgdir/usr/lib/ $pkgdir/usr/share/java/
-
- [ "${CARCH}" = "x86_64" ] && cp native/linux/liblwjgl64.so native/linux/libjinput-linux64.so $pkgdir/usr/lib/
- [ "${CARCH}" = "i686" ] && cp native/linux/liblwjgl.so native/linux/libjinput-linux.so $pkgdir/usr/share/java/
- cp jar/* $pkgdir/usr/share/java/
+package() {
+ _srcdir="$srcdir/$pkgname-$pkgver"
+ cd "$_srcdir"
+ _sharedir="$pkgdir/usr/share"
+ # Install licenses
+ install -d $_sharedir/licenses/$pkgname/3rdparty
+ install -m644 -t $_sharedir/licenses/$pkgname/3rdparty doc/3rdparty/*
+ install -m644 -t $_sharedir/licenses/$pkgname doc/LICENSE
+ rm -rf doc/LICENSE doc/3rdparty
+ # Install docs
+ install -d $_sharedir/doc/$pkgname
+ install -m644 -t $_sharedir/doc/$pkgname doc/*
+ rm -rf doc
+ # Install library files
+ install -d $_sharedir/$pkgname
+ mv * $_sharedir/$pkgname
}
+# vim:set ts=2 sw=2 et: