summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFeng Yu2020-10-03 12:02:52 +0800
committerFeng Yu2020-10-03 12:02:52 +0800
commitdc57365fcb2a4a49fc441065d3feb5c9331a8bc1 (patch)
tree9e9e5dde2a5fadc0d851b4ac0b93e9279726ef84
parentd7bd0d2afe52ad61072bcc5966704c1fce3a5dde (diff)
downloadaur-dc57365fcb2a4a49fc441065d3feb5c9331a8bc1.tar.gz
Upgrade to 1.2.0
-rw-r--r--.SRCINFO31
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
-rw-r--r--lx-music-desktop.install22
4 files changed, 57 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d02c25f554e4..90031d30033f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,28 @@
pkgbase = lx-music-desktop
pkgdesc = A music software based on Electron + Vue. 一个基于 Electron + Vue 开发的音乐软件。
- pkgver = 1.0.1
+ pkgver = 1.2.0
pkgrel = 1
url = https://github.com/lyswhut/lx-music-desktop
+ install = lx-music-desktop.install
arch = x86_64
- groups =
- license =
+ license = Apache-2.0
+ depends = c-ares
+ depends = ffmpeg
depends = gtk3
- depends = libnotify
- depends = nss
+ depends = http-parser
+ depends = libevent
+ depends = libvpx
+ depends = libxslt
depends = libxss
- depends = libxtst
- depends = xdg-utils
- depends = libutil-linux
- depends = at-spi2-core
+ depends = minizip
+ depends = nss
+ depends = re2
+ depends = snappy
+ depends = libnotify
depends = libappindicator-gtk3
- depends = libsecret
- options = !strip
- options = !emptydirs
- source_x86_64 = https://github.com/lyswhut/lx-music-desktop/releases/download/v1.0.1/lx-music-desktop.v1.0.1.x64.deb
- sha512sums_x86_64 = 4bfb09978e8187bfd53642cbc08a2f3754931ae178a458f67a16cf6964af991e5b75a585729217076acc280db620b1824165d8fb34f2e5828f522192c39cce85
+ conflicts = lx-music-desktop
+ source = https://github.com/lyswhut/lx-music-desktop/releases/download/v1.2.0/lx-music-desktop.v1.2.0.x64.pacman
+ md5sums = 7b416a30f9e737e28a01a51077d28632
pkgname = lx-music-desktop-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4035e99309d7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/lx-music-desktop*.pacman
+/lx-music-desktop*.tar*
+/src/
+/pkg/
diff --git a/PKGBUILD b/PKGBUILD
index 53c8a8fecf45..292130a82fac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,23 @@
pkgbase=lx-music-desktop
pkgname=('lx-music-desktop-bin')
-pkgver=1.0.1
+conflicts=('lx-music-desktop')
+pkgver=1.2.0
pkgrel=1
pkgdesc="A music software based on Electron + Vue. 一个基于 Electron + Vue 开发的音乐软件。"
arch=('x86_64')
url="https://github.com/lyswhut/lx-music-desktop"
-license=('')
-groups=('')
-depends=('gtk3' 'libnotify' 'nss' 'libxss' 'libxtst' 'xdg-utils' 'libutil-linux' 'at-spi2-core' 'libappindicator-gtk3' 'libsecret')
-options=('!strip' '!emptydirs')
-source_x86_64=("https://github.com/lyswhut/lx-music-desktop/releases/download/v$pkgver/lx-music-desktop.v$pkgver.x64.deb")
-sha512sums_x86_64=('4bfb09978e8187bfd53642cbc08a2f3754931ae178a458f67a16cf6964af991e5b75a585729217076acc280db620b1824165d8fb34f2e5828f522192c39cce85')
+license=('Apache-2.0')
+# Get depends from command: pacman -Qip lx-music-desktop.v${pkgver}.x64.pacman
+# E.g: pacman -Qip lx-music-desktop.v1.2.0.x64.pacman
+# Then copy the `Depends On(依赖于)` field.
+depends=('c-ares' 'ffmpeg' 'gtk3' 'http-parser' 'libevent' 'libvpx' 'libxslt' 'libxss' 'minizip' 'nss' 're2' 'snappy' 'libnotify' 'libappindicator-gtk3')
+source=("https://github.com/lyswhut/lx-music-desktop/releases/download/v${pkgver}/lx-music-desktop.v${pkgver}.x64.pacman")
+md5sums=('7b416a30f9e737e28a01a51077d28632')
+# copy .INSTALL script from lx-music-desktop.v${pkgver}.x64.pacman
+# E.g: tar xf lx-music-desktop.v1.2.0.x64.pacman .INSTALL && mv -fv .INSTALL lx-music-desktop.install
+install=lx-music-desktop.install
-package_lx-music-desktop-bin(){
- tar xf data.tar.xz -C "${pkgdir}"
+package() {
+ cp -r opt/ usr/ "${pkgdir}"
}
diff --git a/lx-music-desktop.install b/lx-music-desktop.install
new file mode 100644
index 000000000000..7e42ad4baaa2
--- /dev/null
+++ b/lx-music-desktop.install
@@ -0,0 +1,22 @@
+post_install() {
+ :
+#!/bin/bash
+
+# Link to the binary
+ln -sf '/opt/lx-music-desktop/lx-music-desktop' '/usr/bin/lx-music-desktop'
+
+# SUID chrome-sandbox for Electron 5+
+chmod 4755 '/opt/lx-music-desktop/chrome-sandbox' || true
+
+update-mime-database /usr/share/mime || true
+update-desktop-database /usr/share/applications || true
+
+}
+post_remove() {
+ :
+#!/bin/bash
+
+# Delete the link to the binary
+rm -f '/usr/bin/lx-music-desktop'
+
+}