summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhillipe Smith2015-10-18 20:17:54 -0200
committerPhillipe Smith2015-10-18 20:19:22 -0200
commit77655ffb82e95dbad307ab942c1bb6953d3f303f (patch)
tree7b1d5d9c9d0ad9697d9311fedc289c722c1ed52d
parentb58a2659f5808ec9326eb137f23a110a2fa1fdae (diff)
downloadaur-77655ffb82e95dbad307ab942c1bb6953d3f303f.tar.gz
patch to lxdm.c to fix lxdm blank screen
-rw-r--r--.SRCINFO23
-rwxr-xr-xPKGBUILD61
-rwxr-xr-xXsession72
-rw-r--r--lxdm.c.patch50
-rw-r--r--lxdm.conf.in.patch20
-rw-r--r--lxdm.in.patch26
-rw-r--r--lxdm.pam (renamed from lxdm-pam)1
7 files changed, 214 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f95f849926e..82656e9ab794 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,6 +10,7 @@ pkgbase = lxdm-git
license = GPL
makedepends = intltool
makedepends = git
+ makedepends = iso-codes
depends = cairo
depends = dbus-core
depends = gdk-pixbuf2
@@ -18,6 +19,10 @@ pkgbase = lxdm-git
depends = libx11
depends = libxcb
depends = pango
+ depends = xorg-server
+ optdepends = gtk-engines: default GTK+ theme
+ optdepends = iso-codes: show language names in language chooser
+ optdepends = librsvg: display the default background
provides = lxdm
conflicts = lxdm
conflicts = lxdm-svn
@@ -32,17 +37,19 @@ pkgbase = lxdm-git
backup = etc/lxdm/PreShutdown
source = lxdm::git+http://git.lxde.org/git/lxde/lxdm.git
source = http://dl.dropbox.com/u/4813005/lxdm/lxdm-themes.tar.gz
- source = Xsession.patch
- source = lxdm.patch
- source = lxdm.conf.patch
- source = lxdm-pam
+ source = Xsession
+ source = lxdm.in.patch
+ source = lxdm.conf.in.patch
+ source = lxdm.c.patch
+ source = lxdm.pam
source = PostLogout
md5sums = SKIP
md5sums = 1cc5163253149952329671db34ce7907
- md5sums = 9bdf95adb74d81d4b6b6176fb1142090
- md5sums = baed9055e8825a5511712bc095197519
- md5sums = e0653feadbcf9c8fcea1600008b32850
- md5sums = 2897b4f8bf09bdfa060e1be52868873f
+ md5sums = de8be632e7daef6787628ebb0dc94ad1
+ md5sums = b40a5e90b95b07c7fc1120da574c3149
+ md5sums = 1062f248ce6e7b3868fdc60da0645458
+ md5sums = 966499b1900eaa9b9c9021c57073c4df
+ md5sums = c941ef896248bc7c03901b513490425c
md5sums = 5d585acc332056b8d5be3a15d2f20d84
pkgname = lxdm-git
diff --git a/PKGBUILD b/PKGBUILD
index 88c745a4b87e..77b7cd22a36a 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,21 +22,26 @@ backup=('etc/lxdm/lxdm.conf'
'etc/lxdm/PostLogout'
'etc/lxdm/PreReboot'
'etc/lxdm/PreShutdown')
-depends=('cairo' 'dbus-core' 'gdk-pixbuf2' 'glib2' 'gtk2' 'libx11' 'libxcb' 'pango')
-makedepends=('intltool' 'git')
+depends=('cairo' 'dbus-core' 'gdk-pixbuf2' 'glib2' 'gtk2' 'libx11' 'libxcb' 'pango' 'xorg-server')
+makedepends=('intltool' 'git' 'iso-codes')
+optdepends=('gtk-engines: default GTK+ theme'
+ 'iso-codes: show language names in language chooser'
+ 'librsvg: display the default background')
source=('lxdm::git+http://git.lxde.org/git/lxde/lxdm.git'
'http://dl.dropbox.com/u/4813005/lxdm/lxdm-themes.tar.gz'
- 'Xsession.patch'
- 'lxdm.patch'
- 'lxdm.conf.patch'
- 'lxdm-pam'
+ 'Xsession'
+ 'lxdm.in.patch'
+ 'lxdm.conf.in.patch'
+ 'lxdm.c.patch'
+ 'lxdm.pam'
'PostLogout')
md5sums=('SKIP'
'1cc5163253149952329671db34ce7907'
- '9bdf95adb74d81d4b6b6176fb1142090'
- 'baed9055e8825a5511712bc095197519'
- 'e0653feadbcf9c8fcea1600008b32850'
- '2897b4f8bf09bdfa060e1be52868873f'
+ 'de8be632e7daef6787628ebb0dc94ad1'
+ 'b40a5e90b95b07c7fc1120da574c3149'
+ '1062f248ce6e7b3868fdc60da0645458'
+ '966499b1900eaa9b9c9021c57073c4df'
+ 'c941ef896248bc7c03901b513490425c'
'5d585acc332056b8d5be3a15d2f20d84')
pkgver() {
@@ -49,37 +54,36 @@ pkgver() {
fi
}
-build() {
+prepare() {
cd $_gitname
- ./autogen.sh
-
- sed -i '/es_VE/d;/frp/d' po/LINGUAS # Fix language compile errors
-
- ./configure --prefix=/usr --bindir=/usr/bin --sbindir=/usr/bin --sysconfdir=/etc --libexecdir=/usr/lib/lxdm --localstatedir=/var --with-pam
- make
+ patch -Np1 < ../lxdm.in.patch
+ patch -Np1 < ../lxdm.conf.in.patch
+ patch -Np1 < ../lxdm.c.patch
- sed -i 's/getty@tty1/getty@tty7/g' systemd/lxdm.service
- sed -i 's/sbin/bin/' systemd/lxdm.service
- sed -i 's/sbin/bin/' data/lxdm
+ cp ../Xsession data/Xsession
+ cp ../lxdm.pam pam/lxdm
+}
- patch -Np0 < ${srcdir}/lxdm.patch
- patch -Np0 < ${srcdir}/lxdm.conf.patch
- patch -Np0 < ${srcdir}/Xsession.patch
+build() {
+ cd $_gitname
+
+ ./autogen.sh
+ ./configure --prefix=/usr --bindir=/usr/bin --sbindir=/usr/bin --sysconfdir=/etc --libexecdir=/usr/lib/lxdm --localstatedir=/var
+ make
}
package() {
cd $_gitname
- make DESTDIR=${pkgdir} sbindir=/usr/bin install
+ make DESTDIR=${pkgdir} install
chmod 644 "$pkgdir/etc/lxdm/lxdm.conf"
- install -m644 ${srcdir}/lxdm-pam ${pkgdir}/etc/pam.d/lxdm
install -m755 ${srcdir}/PostLogout ${pkgdir}/etc/lxdm/PostLogout
# Home directory
- install -d ${pkgdir}/var/{lib,run}/lxdm
- chown -R 121:121 "$pkgdir/var/lib/lxdm"
+ install -dm 755 ${pkgdir}/var/lib/lxdm
echo 'GDK_CORE_DEVICE_EVENTS=true' > "$pkgdir"/var/lib/lxdm/.pam_environment
+ chown -R 121:121 "$pkgdir/var/lib/lxdm"
# Custom themes
cp -r ${srcdir}/lxdm-themes/* ${pkgdir}/usr/share/lxdm/themes
@@ -87,8 +91,5 @@ package() {
# GNOME Shell extension
mkdir -p "$pkgdir/usr/share/gnome-shell/extensions"
cp -r gnome-shell/LXDM_User_Switch@dgod "$pkgdir/usr/share/gnome-shell/extensions"
-
- # avoid conflict with filesystem>=2012.06
- rm -r ${pkgdir}/var/run
}
diff --git a/Xsession b/Xsession
new file mode 100755
index 000000000000..b5c8782f013c
--- /dev/null
+++ b/Xsession
@@ -0,0 +1,72 @@
+#!/bin/sh
+#
+# LXDM wrapper to run around X sessions.
+
+echo "Running X session wrapper"
+
+if [ $# -eq 1 -a -n "$1" ]; then
+ LXSESSION=$1
+else
+# default session
+ LXSESSION=/usr/bin/startlxde
+fi
+
+# Load profile
+for file in "/etc/profile" "$HOME/.profile" "/etc/xprofile" "$HOME/.xprofile"; do
+ if [ -f "$file" ]; then
+ echo "Loading profile from $file";
+ . "$file"
+ fi
+done
+
+# Load resources
+for file in "/etc/X11/Xresources" "$HOME/.Xresources"; do
+ if [ -f "$file" ]; then
+ echo "Loading resource: $file"
+ xrdb -merge "$file"
+ fi
+done
+
+# Load keymaps
+for file in "/etc/X11/Xkbmap" "$HOME/.Xkbmap"; do
+ if [ -f "$file" ]; then
+ echo "Loading keymap: $file"
+ setxkbmap `cat "$file"`
+ XKB_IN_USE=yes
+ fi
+done
+
+# Load xmodmap if not using XKB
+if [ -z "$XKB_IN_USE" ]; then
+ for file in "/etc/X11/Xmodmap" "$HOME/.Xmodmap"; do
+ if [ -f "$file" ]; then
+ echo "Loading modmap: $file"
+ xmodmap "$file"
+ fi
+ done
+fi
+
+unset XKB_IN_USE
+
+# Run all system xinitrc shell scripts
+xinitdir="/etc/X11/xinit/xinitrc.d"
+if [ -d "$xinitdir" ]; then
+ for script in $xinitdir/*; do
+ echo "Loading xinit script $script"
+ if [ -x "$script" -a ! -d "$script" ]; then
+ . "$script"
+ fi
+ done
+fi
+
+# Run user xsession shell script
+script="$HOME/.xsession"
+if [ -x "$script" -a ! -d "$script" ]; then
+ echo "Loading xsession script $script"
+ . "$script"
+fi
+
+echo "X session wrapper complete, running session $LXSESSION"
+
+exec $LXSESSION
+
diff --git a/lxdm.c.patch b/lxdm.c.patch
new file mode 100644
index 000000000000..d1975863cc18
--- /dev/null
+++ b/lxdm.c.patch
@@ -0,0 +1,50 @@
+--- a/src/lxdm.c 2015-10-18 19:58:05.548666256 -0200
++++ b/src/lxdm.c 2015-10-18 20:10:50.447667243 -0200
+@@ -327,17 +327,10 @@
+ s->idle=FALSE;
+ sprintf(temp,":%d",s->display);
+ setenv("DISPLAY",temp,1);
+- #ifndef DISABLE_XAUTH
+- sprintf(temp,"/var/run/lxdm/lxdm-:%d.auth",s->display);
+- setenv("XAUTHORITY",temp,1);
+- #endif
+ g_message("prepare greeter on %s\n",temp);
+ ui_prepare();
+ lxsession_set_active(s);
+ g_message("start greeter on %s\n",temp);
+- #ifndef DISABLE_XAUTH
+- unsetenv("XAUTHORITY");
+- #endif
+ return s;
+ }
+
+@@ -493,10 +486,6 @@
+ {
+ arg[arc++] = g_strdup("-novtswitch");
+ }
+-#ifndef DISABLE_XAUTH
+- arg[arc++] = g_strdup("-auth");
+- arg[arc++] = g_strdup_printf("/var/run/lxdm/lxdm-:%d.auth",s->display);
+-#endif
+ arg[arc] = NULL;
+ p=g_strjoinv(" ", arg);
+ g_strfreev(arg);
+@@ -705,7 +694,7 @@
+
+ authfile = g_strdup_printf("/var/run/lxdm/lxdm-:%d.auth",s->display);
+
+- setenv("XAUTHORITY",authfile,1);
++ //setenv("XAUTHORITY",authfile,1);
+ remove(authfile);
+ xauth_write_file(authfile,s->display,s->mcookie);
+ g_free(authfile);
+@@ -1009,9 +998,6 @@
+ g_message("%ld: start xserver in %d retry",time(NULL),i);
+ if(s->dpy==NULL)
+ exit(EXIT_FAILURE);
+- #ifndef DISABLE_XAUTH
+- unsetenv("XAUTHORITY");
+- #endif
+
+ if(s->option && g_key_file_has_key(config,s->option,"numlock",NULL))
+ {
diff --git a/lxdm.conf.in.patch b/lxdm.conf.in.patch
new file mode 100644
index 000000000000..50435a60cfca
--- /dev/null
+++ b/lxdm.conf.in.patch
@@ -0,0 +1,20 @@
+--- a/data/lxdm.conf.in 2015-10-18 19:22:46.386331477 -0200
++++ b/data/lxdm.conf.in 2015-10-18 19:33:38.514873184 -0200
+@@ -23,7 +23,7 @@
+
+ [server]
+ ## arg used to start xserver, not fully function
+-# arg=/usr/bin/X -background vt1
++arg=/usr/bin/X -background vt1
+ # uncomment this if you really want xserver listen to tcp
+ # tcp_listen=1
+ # uncoment this if you want reset the xserver after logou
+@@ -34,7 +34,7 @@
+ gtk_theme=Clearlooks
+
+ ## background of the greeter
+-bg=/usr/share/backgrounds/default.png
++#bg=/usr/share/backgrounds/default.png
+
+ ## if show bottom pane
+ bottom_pane=1
diff --git a/lxdm.in.patch b/lxdm.in.patch
new file mode 100644
index 000000000000..be6c8283b1c7
--- /dev/null
+++ b/lxdm.in.patch
@@ -0,0 +1,26 @@
+--- a/data/lxdm.in 2015-10-18 19:22:46.386331477 -0200
++++ b/data/lxdm.in 2015-10-18 19:28:46.354787701 -0200
+@@ -1,21 +1,13 @@
+ #!/bin/sh
+
+-[ -f /etc/sysconfig/i18n ] && . /etc/sysconfig/i18n
+-
+-if [ -z "$LANG" -a -e /etc/sysconfig/language ]; then
+- . /etc/sysconfig/language
+- if [ -n "$RC_LANG"]; then
+- LANG=$RC_LANG
+- fi
++if [ -r /etc/profile.d/locale.sh ]; then
++ . /etc/profile.d/locale.sh
+ fi
+
+ if [ -n "$LANG" ]; then
+ export LANG
+ fi
+
+-[ -f /etc/sysconfig/desktop ] && . /etc/sysconfig/desktop
+-[ -f /etc/sysconfig/windowmanager ] && . /etc/sysconfig/windowmanager
+-
+ if [ -n "$DEFAULT_WM" ]; then
+ PREFERRED=$DEFAULT_WM
+ fi
diff --git a/lxdm-pam b/lxdm.pam
index 659c884fb6ad..76b8869a2515 100644
--- a/lxdm-pam
+++ b/lxdm.pam
@@ -5,4 +5,3 @@ account include system-login
password include system-login
session include system-login
-session optional pam_gnome_keyring.so auto_start
--session optional pam_systemd.so