summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIlias Stamatis2015-06-08 16:24:03 +0300
committerIlias Stamatis2015-06-08 16:24:03 +0300
commitc731b439af663183d9422850cdd35fc65c5f23de (patch)
tree98dbdeba7f7dfc9c900cccba4d96a62af09a4768
downloadaur-c731b439af663183d9422850cdd35fc65c5f23de.tar.gz
initial commit
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD49
-rw-r--r--greeter.ui.ArchlinuxFull226
-rw-r--r--lxdm-themes.install11
4 files changed, 315 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c026c4b32cd4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = lxdm-themes
+ pkgdesc = Archlinux, ArchlinuxFull, ArchlinuxTop, Arch-Dark, Arch-Stripes and IndustrialArch lxdm themes
+ pkgver = 1
+ pkgrel = 1
+ url = https://wiki.archlinux.org/index.php/LXDM#Themes
+ install = lxdm-themes.install
+ arch = any
+ license = GPL
+ license = CCPL
+ depends = lxdm
+ conflicts = archlinux-lxdm-theme
+ conflicts = archlinux-lxdm-theme-full
+ conflicts = archlinux-lxdm-theme-top
+ conflicts = industrial-arch-lxdm
+ noextract = lxdm-theme.tar.gz
+ noextract = archlinux-lxdm.tar.gz
+ source = http://allanmcrae.com/files/lxdm-theme.tar.gz
+ source = greeter.ui.ArchlinuxFull
+ source = http://xdsl.hi2.ro/work/archlinux-lxdm.tar.gz
+ source = git+https://github.com/M4rQu1Nh0S/industrial-arch.git
+ source = http://dl.dropbox.com/u/4813005/lxdm/lxdm-themes.tar.gz
+ sha256sums = 1eeaee69da8dd0ab28fc6967b06d4594980808bed83e822858a31b46926acbe7
+ sha256sums = 09c66ccc6de32c6685b4f27cbfd2f2a2a679d4e961eebcbc80c294eb8d0f47d3
+ sha256sums = ad98f832de33909f321e87b10e0af2da156b91e0abf4b7e877e506dbed2fdd6e
+ sha256sums = SKIP
+ sha256sums = 2e6ad13c483559e3778f81ba4cf3b88b96034f5b38877ac3dad85b9b16def6e3
+
+pkgname = lxdm-themes
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c683451dea14
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Ilias Stamatis <stamatis.iliass at gmail dot com>
+
+pkgname=lxdm-themes
+pkgver=1
+pkgrel=1
+pkgdesc="Archlinux, ArchlinuxFull, ArchlinuxTop, Arch-Dark, Arch-Stripes and IndustrialArch lxdm themes"
+arch=(any)
+url="https://wiki.archlinux.org/index.php/LXDM#Themes"
+license=('GPL' 'CCPL')
+depends=('lxdm')
+conflicts=('archlinux-lxdm-theme' 'archlinux-lxdm-theme-full'
+ 'archlinux-lxdm-theme-top' 'industrial-arch-lxdm')
+install=lxdm-themes.install
+source=('http://allanmcrae.com/files/lxdm-theme.tar.gz' # Archlinux
+ 'greeter.ui.ArchlinuxFull' # ArchlinuxFull
+ 'http://xdsl.hi2.ro/work/archlinux-lxdm.tar.gz' # ArchlinuxTop
+ 'git+https://github.com/M4rQu1Nh0S/industrial-arch.git' # IndustrialArch
+ 'http://dl.dropbox.com/u/4813005/lxdm/lxdm-themes.tar.gz') # Arch-Dark, Arch-Stripes
+noextract=('lxdm-theme.tar.gz' 'archlinux-lxdm.tar.gz')
+sha256sums=('1eeaee69da8dd0ab28fc6967b06d4594980808bed83e822858a31b46926acbe7'
+ '09c66ccc6de32c6685b4f27cbfd2f2a2a679d4e961eebcbc80c294eb8d0f47d3'
+ 'ad98f832de33909f321e87b10e0af2da156b91e0abf4b7e877e506dbed2fdd6e'
+ 'SKIP'
+ '2e6ad13c483559e3778f81ba4cf3b88b96034f5b38877ac3dad85b9b16def6e3')
+
+prepare() {
+ # avoid file conflicts by extracting themes in different dirs
+ cd "$srcdir"
+ mkdir Archlinux ArchlinuxTop
+ bsdtar -xf lxdm-theme.tar.gz -C Archlinux
+ bsdtar -xf archlinux-lxdm.tar.gz -C ArchlinuxTop
+}
+
+package() {
+ themesdir="${pkgdir}/usr/share/lxdm/themes"
+ mkdir -p "${themesdir}/ArchlinuxFull"
+ mkdir -p "${themesdir}/Arch-Dark"
+ mkdir -p "${themesdir}/Arch-Stripes"
+ mkdir -p "${themesdir}/IndustrialArch"
+
+ cd "$srcdir"
+ cp -r Archlinux "$themesdir"
+ cp -a Archlinux/* "${themesdir}/ArchlinuxFull"
+ cp greeter.ui.ArchlinuxFull "${themesdir}/ArchlinuxFull"
+ cp -r ArchlinuxTop "$themesdir"
+ cp -a lxdm-themes/ArchDark/* "${themesdir}/Arch-Dark"
+ cp -a lxdm-themes/ArchStripes/* "${themesdir}/Arch-Stripes"
+ cp -a industrial-arch/* "${themesdir}/IndustrialArch"
+}
diff --git a/greeter.ui.ArchlinuxFull b/greeter.ui.ArchlinuxFull
new file mode 100644
index 000000000000..13003e4ec369
--- /dev/null
+++ b/greeter.ui.ArchlinuxFull
@@ -0,0 +1,226 @@
+<?xml version="1.0"?>
+<interface>
+ <!-- interface-requires gtk+ 2.12 -->
+ <!-- interface-naming-policy project-wide -->
+ <object class="GtkWindow" id="lxdm">
+ <property name="decorated">False</property>
+ <child>
+ <object class="GtkVBox" id="vbox1">
+ <property name="visible">True</property>
+ <property name="orientation">vertical</property>
+ <child>
+ <object class="GtkLabel" id="time">
+ <property name="visible">True</property>
+ <property name="xalign">1</property>
+ <property name="xpad">12</property>
+ <property name="ypad">12</property>
+ <property name="single_line_mode">True</property>
+ </object>
+ <packing>
+ <property name="expand">False</property>
+ <property name="position">0</property>
+ </packing>
+ </child>
+ <child>
+ <object class="GtkAlignment" id="alignment1">
+ <property name="visible">True</property>
+ <property name="xscale">0</property>
+ <property name="yscale">0</property>
+ <child>
+ <object class="GtkVBox" id="vbox2">
+ <property name="visible">True</property>
+ <property name="orientation">vertical</property>
+ <child>
+ <object class="GtkImage" id="image1">
+ <property name="visible">True</property>
+ <property name="pixbuf">panel.png</property>
+ </object>
+ <packing>
+ <property name="position">0</property>
+ </packing>
+ </child>
+ <child>
+ <object class="GtkAlignment" id="alignment2">
+ <property name="visible">True</property>
+ <property name="xscale">0</property>
+ <property name="yscale">0</property>
+ <child>
+ <object class="GtkHBox" id="hbox3">
+ <property name="visible">True</property>
+ <property name="spacing">12</property>
+ <child>
+ <object class="GtkLabel" id="prompt">
+ <property name="visible">True</property>
+ <property name="label" translatable="yes">User:</property>
+ <property name="yalign">0.2</property>
+ </object>
+ <packing>
+ <property name="expand">False</property>
+ <property name="fill">False</property>
+ <property name="position">0</property>
+ </packing>
+ </child>
+ <child>
+ <object class="GtkIconView" id="user_list">
+ <property name="visible">True</property>
+ <property name="can_focus">True</property>
+ <property name="item-padding">1</property>
+ <property name="margin">2</property>
+ <property name="column-spacing">0</property>
+ <property name="row-spacing">1</property>
+ </object>
+ <packing>
+ <property name="expand">False</property>
+ <property name="fill">False</property>
+ <property name="position">1</property>
+ </packing>
+ </child>
+ <child>
+ <object class="GtkEntry" id="login_entry">
+ <property name="visible">True</property>
+ <property name="can_focus">True</property>
+ <property name="invisible_char">&#x2022;</property>
+ </object>
+ <packing>
+ <property name="expand">False</property>
+ <property name="fill">False</property>
+ <property name="position">1</property>
+ </packing>
+ </child>
+ </object>
+ </child>
+ </object>
+ <packing>
+ <property name="position">1</property>
+ </packing>
+ </child>
+ </object>
+ </child>
+ </object>
+ <packing>
+ <property name="position">1</property>
+ </packing>
+ </child>
+ <child>
+ <object class="GtkEventBox" id="bottom_pane">
+ <property name="visible">True</property>
+ <property name="app_paintable">True</property>
+ <property name="visible_window">False</property>
+ <child>
+ <object class="GtkHBox" id="bottom_hbox">
+ <property name="visible">True</property>
+ <property name="border_width">6</property>
+ <property name="spacing">12</property>
+ <child>
+ <object class="GtkHBox" id="sessions_box">
+ <property name="visible">True</property>
+ <property name="spacing">6</property>
+ <child>
+ <object class="GtkLabel" id="label2">
+ <property name="visible">True</property>
+ <property name="label" translatable="yes">Desktop:</property>
+ </object>
+ <packing>
+ <property name="expand">False</property>
+ <property name="position">0</property>
+ </packing>
+ </child>
+ <child>
+ <object class="GtkComboBoxEntry" id="sessions">
+ <property name="visible">True</property>
+ <property name="text_column">0</property>
+ </object>
+ <packing>
+ <property name="expand">False</property>
+ <property name="position">2</property>
+ </packing>
+ </child>
+ </object>
+ <packing>
+ <property name="expand">False</property>
+ <property name="position">0</property>
+ </packing>
+ </child>
+ <child>
+ <object class="GtkHBox" id="lang_box">
+ <property name="visible">True</property>
+ <property name="spacing">6</property>
+ <child>
+ <object class="GtkImage" id="image3">
+ <property name="visible">True</property>
+ <!--<property name="pixbuf">lang.png</property>-->
+ </object>
+ <packing>
+ <property name="expand">False</property>
+ <property name="position">0</property>
+ </packing>
+ </child>
+ <child>
+ <object class="GtkLabel" id="label_lang">
+ <property name="visible">True</property>
+ <property name="label" translatable="yes">Language:</property>
+ </object>
+ <packing>
+ <property name="expand">False</property>
+ <property name="position">1</property>
+ </packing>
+ </child>
+ <child>
+ <object class="GtkComboBoxEntry" id="lang">
+ <property name="visible">True</property>
+ <property name="text_column">0</property>
+ </object>
+ <packing>
+ <property name="expand">False</property>
+ <property name="position">2</property>
+ </packing>
+ </child>
+ </object>
+ <packing>
+ <property name="expand">False</property>
+ <property name="position">1</property>
+ </packing>
+ </child>
+ <child>
+ <object class="GtkLabel" id="label_keyboard">
+ <property name="label" translatable="yes">Keyboard:</property>
+ </object>
+ <packing>
+ <property name="expand">False</property>
+ <property name="position">2</property>
+ </packing>
+ </child>
+ <child>
+ <object class="GtkComboBoxEntry" id="keyboard"/>
+ <packing>
+ <property name="expand">False</property>
+ <property name="position">3</property>
+ </packing>
+ </child>
+ <child>
+ <object class="GtkButton" id="exit">
+ <property name="label">gtk-quit</property>
+ <property name="visible">True</property>
+ <property name="can_focus">True</property>
+ <property name="receives_default">True</property>
+ <property name="relief">none</property>
+ <property name="use_stock">True</property>
+ </object>
+ <packing>
+ <property name="expand">False</property>
+ <property name="pack_type">end</property>
+ <property name="position">4</property>
+ </packing>
+ </child>
+ </object>
+ </child>
+ </object>
+ <packing>
+ <property name="expand">False</property>
+ <property name="position">2</property>
+ </packing>
+ </child>
+ </object>
+ </child>
+ </object>
+</interface>
diff --git a/lxdm-themes.install b/lxdm-themes.install
new file mode 100644
index 000000000000..fa07074f132d
--- /dev/null
+++ b/lxdm-themes.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo "==> Don't forget to manually edit /etc/lxdm/lxdm.conf and set your prefered theme"
+ echo " eg. theme=ArchlinuxFull or theme=Arch-Dark"
+ echo " ls /usr/share/lxdm/themes, to see all available themes"
+}
+
+post_upgrade() {
+ echo "==> Don't forget to manually edit /etc/lxdm/lxdm.conf and set your prefered theme"
+ echo " eg. theme=ArchlinuxFull or theme=Arch-Dark"
+ echo " ls /usr/share/lxdm/themes, to see all available themes"
+}