summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Cianciolo2016-11-14 01:49:19 +0100
committerMario Cianciolo2016-11-14 01:49:19 +0100
commitd2c90e117ee055f1c356b478c156f80a84cb0fb6 (patch)
tree4e05bbbe97690b132924a1865675f666ebb75d4c
downloadaur-d2c90e117ee055f1c356b478c156f80a84cb0fb6.tar.gz
Package name change (initial commit with this name)
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD40
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2b352c90c00b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = lxpanel-multiload-ng-plugin-gtk3-git
+ pkgdesc = Modern graphical system monitor, LxPanel plugin
+ pkgver = r898.1661963
+ pkgrel = 2
+ url = https://udda.github.io/multiload-ng/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = intltool
+ makedepends = git
+ depends = gtk3
+ depends = cairo
+ depends = lxpanel-gtk3>=0.5.8
+ conflicts = lxpanel-multiload-ng-plugin-gtk2
+ conflicts = lxpanel-multiload-ng-plugin-gtk3
+ conflicts = lxpanel-multiload-ng-plugin-gtk2-git
+ source = git+https://github.com/udda/multiload-ng.git
+ md5sums = SKIP
+
+pkgname = lxpanel-multiload-ng-plugin-gtk3-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..884e277dea60
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Mario Cianciolo <mr.udda at gmail dot com>
+# Co-maintainer: Michael Kogan <michael.kogan at gmx dot net>
+
+# This file is automatically generated from multiload-ng source.
+
+pkgname='lxpanel-multiload-ng-plugin-gtk3-git'
+pkgdesc='Modern graphical system monitor, LxPanel plugin'
+pkgver=r898.1661963
+pkgrel=2
+
+makedepends=('intltool' 'git')
+depends=('gtk3' 'cairo' 'lxpanel-gtk3>=0.5.8')
+
+conflicts=('lxpanel-multiload-ng-plugin-gtk2' 'lxpanel-multiload-ng-plugin-gtk3' 'lxpanel-multiload-ng-plugin-gtk2-git')
+
+replaces=('lxpanel-multiload-ng-applet-gtk3-git')
+
+source=("git+https://github.com/udda/multiload-ng.git")
+md5sums=('SKIP')
+
+arch=('i686' 'x86_64')
+url='https://udda.github.io/multiload-ng/'
+license=('GPL2')
+
+build() {
+ cd "multiload-ng"
+ ./autogen.sh
+ ./configure --prefix=/usr --with-gtk=3.0 --disable-deprecations --without-awn --without-indicator --with-lxpanel --without-mate --without-standalone --without-systray --without-xfce4
+ make
+}
+
+package() {
+ cd "multiload-ng"
+ make DESTDIR="$pkgdir" install
+}
+
+pkgver() {
+ cd "multiload-ng"
+ printf -- "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}