summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel Retana2018-04-29 21:52:50 -0600
committerGabriel Retana2018-04-29 21:52:50 -0600
commitd40cd8dd4f7922e53d2292a3839c1bb6c91dc4ea (patch)
tree8cba48cd5bc8a655ca1e17901843687d584a06e6
downloadaur-d40cd8dd4f7922e53d2292a3839c1bb6c91dc4ea.tar.gz
First commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6bba3463bc9b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = lxqt-arc-dark-theme-git
+ pkgdesc = A dark theme for LXQt based on Arc
+ pkgver = latest
+ pkgrel = 1
+ url = https://github.com/gabretana/lxqt-arc-dark-theme
+ arch = any
+ license = GPL
+ optdepends = kvantum-theme-arc: recommended kvantum style
+ source = git+https://github.com/gabretana/lxqt-arc-dark-theme.git
+ md5sums = SKIP
+
+pkgname = lxqt-arc-dark-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7105c2e73672
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+### Maintainer: Gabriel Retana <isseigx at protonmail dot ch>
+
+pkgname=lxqt-arc-dark-theme-git
+pkgver=latest
+pkgrel=1
+pkgdesc="A dark theme for LXQt based on Arc"
+arch=('any')
+url="https://github.com/gabretana/lxqt-arc-dark-theme"
+license=('GPL')
+optdepends=('kvantum-theme-arc: recommended kvantum style')
+_theme='arc-dark'
+_repo='lxqt-arc-dark-theme'
+source=("git+https://github.com/gabretana/lxqt-arc-dark-theme.git")
+md5sums=('SKIP')
+
+pkgver() {
+ echo "$(git -C "${srcdir}/${_repo}" rev-list --count HEAD)"
+}
+
+package() {
+ install -d "${pkgdir}"/usr/share/lxqt/themes/"${_theme}"
+ cp -r "${srcdir}/${_repo}/${_theme}"/* "${pkgdir}"/usr/share/lxqt/themes/"${_theme}"/ --preserve=mode
+}