summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Mattern2016-10-06 22:05:22 +0200
committerPeter Mattern2016-10-06 22:05:22 +0200
commitdee005fb84df64575711970d8c9bd41cc34e7fe7 (patch)
tree9d5ebbda8d6a350468d649a7ae9836be6a752586
downloadaur-dee005fb84df64575711970d8c9bd41cc34e7fe7.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD32
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6d820f784303
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Thu Oct 6 20:05:10 UTC 2016
+pkgbase = lxqt-build-tools-git
+ pkgdesc = Tools to build LXQt and components maintained by the project.
+ pkgver = r200.46d8398
+ pkgrel = 1
+ url = https://github.com/lxde/lxqt-build-tools
+ arch = any
+ license = LGPL
+ makedepends = git
+ makedepends = cmake
+ makedepends = qt5-base
+ makedepends = qt5-tools
+ makedepends = qt5-x11extras
+ makedepends = libqtxdg-git
+ makedepends = kwindowsystem
+ provides = lxqt-build-tools
+ conflicts = lxqt-build-tools
+ source = git+https://github.com/lxde/lxqt-build-tools.git#branch=make-it-work
+ sha256sums = SKIP
+
+pkgname = lxqt-build-tools-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..70424b453328
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Peter Mattern <pmattern at arcor dot de>
+
+_pkgname=lxqt-build-tools
+pkgname=$_pkgname-git
+pkgver=r200.46d8398
+pkgrel=1
+pkgdesc='Tools to build LXQt and components maintained by the project.'
+arch=('any')
+url='https://github.com/lxde/lxqt-build-tools'
+license=('LGPL')
+makedepends=('git' 'cmake' "qt5-"{base,tools,x11extras} 'libqtxdg-git' 'kwindowsystem')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+https://github.com/lxde/lxqt-build-tools.git#branch=make-it-work")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ rm -Rf build ; mkdir build
+ cd build
+ cmake $srcdir/$_pkgname -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}