summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJerome Leclanche2015-06-09 21:57:43 +0200
committerJerome Leclanche2015-06-09 21:57:43 +0200
commit217e27bebbfa9e00cf89eb2445a9648e3f6aa11e (patch)
tree3622a9848e5fc2fd0fa756812d030f2cd0caaafb
downloadaur-217e27bebbfa9e00cf89eb2445a9648e3f6aa11e.tar.gz
Initial import from old AUR
-rw-r--r--.SRCINFO37
-rw-r--r--PKGBUILD55
2 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a8ff43c71dae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,37 @@
+pkgbase = lxqt-desktop-git
+ pkgdesc = The LXQt desktop
+ pkgver = 0.9.0
+ pkgrel = 2
+ url = http://lxqt.org
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = pcmanfm-qt-git
+ depends = lxqt-about-git
+ depends = lxqt-admin-git
+ depends = lxqt-common-git
+ depends = lxqt-config-git
+ depends = lxqt-globalkeys-git
+ depends = lxqt-notificationd-git
+ depends = lxqt-openssh-askpass
+ depends = lxqt-panel-git
+ depends = lxqt-policykit-git
+ depends = lxqt-powermanagement-git
+ depends = lxqt-qtplugin-git
+ depends = lxqt-runner-git
+ depends = lxqt-session-git
+ optdepends = lximage-qt-git: The LXQt image viewer
+ optdepends = openbox: Recommended window manager
+ optdepends = sddm: Recommended display manager
+ optdepends = qterminal: Pure Qt terminal
+ optdepends = juffed: Pure Qt text editor (Kate clone)
+ optdepends = screengrab: Screenshot capture
+ optdepends = qps: Task Monitoring
+ provides = lxqt-desktop
+ conflicts = lxqt-desktop
+ source = lxqt-desktop::git+https://github.com/lxde/lxqt.git
+ sha256sums = SKIP
+
+pkgname = lxqt-desktop-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a50e966982ed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Jerome Leclanche <jerome@leclan.ch>
+
+_pkgname=lxqt-desktop
+pkgname=$_pkgname-git
+pkgver=0.9.0
+pkgrel=2
+pkgdesc="The LXQt desktop"
+arch=("i686" "x86_64")
+url="http://lxqt.org"
+license=("GPL2")
+depends=(
+ "pcmanfm-qt-git"
+ # components
+ "lxqt-about-git"
+ "lxqt-admin-git"
+ "lxqt-common-git"
+ "lxqt-config-git"
+ "lxqt-globalkeys-git"
+ "lxqt-notificationd-git"
+ "lxqt-openssh-askpass"
+ "lxqt-panel-git"
+ "lxqt-policykit-git"
+ "lxqt-powermanagement-git"
+ "lxqt-qtplugin-git"
+ "lxqt-runner-git"
+ "lxqt-session-git"
+)
+optdepends=(
+ "lximage-qt-git: The LXQt image viewer"
+ "openbox: Recommended window manager"
+ "sddm: Recommended display manager"
+ "qterminal: Pure Qt terminal"
+ "juffed: Pure Qt text editor (Kate clone)"
+ "screengrab: Screenshot capture"
+ "qps: Task Monitoring"
+)
+makedepends=("git")
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_pkgname::git+https://github.com/lxde/lxqt.git")
+sha256sums=("SKIP")
+
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --always | sed "s/-/./g"
+}
+
+build() {
+ msg2 "This is a metapackage. Nothing will be built."
+}
+
+package() {
+ msg2 "This is a metapackage. Nothing will be installed."
+}