summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlibrewish2020-02-26 10:50:43 +0530
committerlibrewish2020-02-26 10:50:43 +0530
commitc83ba13a489f8a0e569b2574af2efd70f63632e7 (patch)
treed0f10c47a55659fd44311fff1c476df7b00d31cd
parentd786d76ce40ea96ca4ea5f69120236c9bd0d7524 (diff)
downloadaur-c83ba13a489f8a0e569b2574af2efd70f63632e7.tar.gz
make it work
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD21
2 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c12cdc167982..282a9bae7229 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = lxqt-kcm-integration-git
pkgdesc = LXQt KCM Integration
- pkgver = 0.0.1
+ pkgver = r31.f5995a0
pkgrel = 1
url = http://lxqt.org
+ arch = i686
arch = x86_64
license = LGPL2
makedepends = git
makedepends = cmake
+ makedepends = lxqt-build-tools-git
depends = kde-cli-tools
depends = kglobalaccel
depends = kwin
diff --git a/PKGBUILD b/PKGBUILD
index f588e962f6dc..6307564f9cf6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,21 @@
-# Maintainer: Alf Gaida <agaida@siduction.org>
+# Maintainer: Librewish <librewish@gmail.com>
+# Contributor: Alf Gaida <agaida@siduction.org>
_pkgname=lxqt-kcm-integration
-pkgname=$pkgname-git
-pkgver=0.0.1
+pkgname=$_pkgname-git
+pkgver=r31.f5995a0
pkgrel=1
pkgdesc="LXQt KCM Integration"
-arch=("x86_64")
+arch=("i686" "x86_64")
url="http://lxqt.org"
license=("LGPL2")
depends=("kde-cli-tools" "kglobalaccel" "kwin" "plasma-workspace")
optdepends=('bluedevil: needed for lxqt-kcm-bluetooth'
'kde-gtk-config: needed for lxqt-kcm-appearance'
'kinfocenter: needed for lxqt-kcm-systeminfo'
- 'plasma-desktop: needed for lxqt-kcm-appearance colors and styles')
-makedepends=("git" "cmake")
+ 'plasma-desktop: needed for lxqt-kcm-appearance colors and styles'
+)
+makedepends=("git" "cmake" "lxqt-build-tools-git")
provides=("$_pkgname")
conflicts=("$_pkgname")
source=("git+https://github.com/lxqt/$_pkgname.git")
@@ -21,8 +23,11 @@ sha256sums=("SKIP")
pkgver() {
- cd "$srcdir/$_pkgname"
- git describe --always | sed "s/-/./g"
+ cd "$srcdir/lxqt-kcm-integration"
+
+# Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+
}
build() {