summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Mattern2024-04-24 14:36:52 +0200
committerPeter Mattern2024-04-25 11:36:10 +0200
commit750bedc8d92b3eaf380396264f236b0b129dd9e3 (patch)
tree34e342f370ed6b7dc82cf376caccdae3d55cb2ff
parentd600a036fe43b5732500463dbfbb31793a1f8eb9 (diff)
downloadaur-lxqt-notificationd-git.tar.gz
Miscellaneous updates
* upstream URL (homepage) * license string * dependencies * improve pkgver()
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD30
2 files changed, 21 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54b84309b5dd..bb14dbf66dc8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = lxqt-notificationd-git
pkgdesc = LXQt notification daemon and library.
- pkgver = 1.3.0.15.g51541d5
+ pkgver = 2.0.0
pkgrel = 1
- url = https://lxqt.org
+ url = https://lxqt-project.org
arch = i686
arch = x86_64
- license = LGPL2.1
+ license = LGPL-2.1-only
makedepends = git
makedepends = cmake
- makedepends = qt5-tools
+ makedepends = qt6-tools
makedepends = lxqt-build-tools-git
- depends = qt5-base
+ depends = layer-shell-qt
depends = liblxqt-git
- depends = kwindowsystem5
+ depends = kwindowsystem
provides = lxqt-notificationd
provides = notification-daemon
conflicts = lxqt-notificationd
diff --git a/PKGBUILD b/PKGBUILD
index 9832873e9151..07f16659fa54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,36 @@
# Maintainer: Chih-Hsuan Yen <yan12125@gmail.com>
+# Co-Maintainer: Peter Mattern <pmattern at arcor dot de>
# Contributor: Jerome Leclanche <jerome@leclan.ch>
_pkgname=lxqt-notificationd
pkgname=$_pkgname-git
-pkgver=1.3.0.15.g51541d5
+pkgver=2.0.0
pkgrel=1
pkgdesc="LXQt notification daemon and library."
arch=("i686" "x86_64")
-url="https://lxqt.org"
-license=("LGPL2.1")
-depends=("qt5-base" "liblxqt-git" "kwindowsystem5")
-makedepends=("git" "cmake" "qt5-tools" "lxqt-build-tools-git")
+url="https://lxqt-project.org"
+license=("LGPL-2.1-only")
+depends=('layer-shell-qt' 'liblxqt-git' 'kwindowsystem')
+makedepends=('git' 'cmake' 'qt6-tools' 'lxqt-build-tools-git')
provides=("$_pkgname" "notification-daemon")
conflicts=("$_pkgname")
source=("git+https://github.com/lxqt/$_pkgname.git")
sha256sums=('SKIP')
-
pkgver() {
- cd "$srcdir/$_pkgname"
- git describe --always | sed "s/-/./g"
+ cd "$srcdir/$_pkgname"
+ git describe --always | sed "s/-/.r/;s/-/./"
}
build() {
- mkdir -p build
- cd build
- cmake "$srcdir/$_pkgname" \
- -DCMAKE_INSTALL_PREFIX=/usr
- make
+ mkdir -p build
+ cd build
+ cmake "$srcdir/$_pkgname" \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
}
package() {
- cd build
- make DESTDIR="$pkgdir" install
+ cd build
+ make DESTDIR="$pkgdir" install
}