summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJerome Leclanche2015-06-09 21:59:53 +0200
committerJerome Leclanche2015-06-09 21:59:53 +0200
commit43a824d7230be62de65fb23671fff8f18db8c161 (patch)
tree79418060eb2c3ed3d9f7270809c481e7e6fc0c97
downloadaur-43a824d7230be62de65fb23671fff8f18db8c161.tar.gz
Initial import from old AUR
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD35
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e62a63b16d47
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = lxqt-notificationd-git
+ pkgdesc = LXQt notification daemon and library.
+ pkgver = 0.9.0.14.g41a22ef
+ pkgrel = 1
+ url = http://lxqt.org
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = cmake
+ makedepends = qt5-tools
+ depends = lxqt-common
+ depends = liblxqt-git
+ depends = kwindowsystem
+ provides = lxqt-notificationd
+ conflicts = lxqt-notificationd
+ source = git+https://github.com/lxde/lxqt-notificationd.git
+ sha256sums = SKIP
+
+pkgname = lxqt-notificationd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..67396358e221
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Jerome Leclanche <jerome@leclan.ch>
+
+_pkgname=lxqt-notificationd
+pkgname=$_pkgname-git
+pkgver=0.9.0.14.g41a22ef
+pkgrel=1
+pkgdesc="LXQt notification daemon and library."
+arch=("i686" "x86_64")
+url="http://lxqt.org"
+license=("GPL2")
+depends=("lxqt-common" "liblxqt-git" "kwindowsystem")
+makedepends=("git" "cmake" "qt5-tools")
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+https://github.com/lxde/$_pkgname.git")
+sha256sums=("SKIP")
+
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --always | sed "s/-/./g"
+}
+
+build() {
+ mkdir -p build
+ cd build
+ cmake "$srcdir/$_pkgname" \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}