summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Mattern2016-09-21 00:48:15 +0200
committerPeter Mattern2016-09-21 01:00:48 +0200
commit706b7b868777c6936ca51f127c3901899274307f (patch)
tree930849c0b749171fd030d4c68dc700083b304ef9
parent8a7532178f1fa53406da6ef61386b6b38fd2c927 (diff)
downloadaur-706b7b868777c6936ca51f127c3901899274307f.tar.gz
Polish after adopting package
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD49
2 files changed, 29 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8343ef101919..ab32c6cbcf78 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,25 @@
# Generated by mksrcinfo v8
-# Mon Sep 5 19:34:41 UTC 2016
+# Tue Sep 20 23:00:23 UTC 2016
pkgbase = lxqt-panel-git
pkgdesc = The LXQt desktop panel
pkgver = 0.10.0.129.g1c48664
pkgrel = 1
- url = http://lxqt.org
+ url = https://github.com/lxde/lxqt-panel
arch = i686
arch = x86_64
license = GPL2
makedepends = git
makedepends = cmake
makedepends = qt5-tools
- depends = liblxqt-git
depends = kwindowsystem
depends = kguiaddons
depends = solid
- depends = lxqt-globalkeys
depends = menu-cache
depends = libxcomposite
depends = lxmenu-data
depends = libdbusmenu-qt5
+ depends = liblxqt-git
+ depends = lxqt-globalkeys
optdepends = alsa-lib: Recompile for Alsa support in volume control plugin
optdepends = libpulse: Recompile for PulseAudio support in volume control plugin
optdepends = lm_sensors: Recompile for Sensors (battery) plugin
diff --git a/PKGBUILD b/PKGBUILD
index 1fa08e0fc210..bd3ae14c5dab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,26 @@
-# Maintainer: Jerome Leclanche <jerome@leclan.ch>
+# Maintainer: Peter Mattern <pmattern@arcor.de>
+# Contributor: Yen Chi Hsuan <yan12125@gmail.com>
+# Contributor: Jerome Leclanche <jerome@leclan.ch>
_pkgname=lxqt-panel
pkgname=$_pkgname-git
pkgver=0.10.0.129.g1c48664
pkgrel=1
-pkgdesc="The LXQt desktop panel"
-arch=("i686" "x86_64")
-url="http://lxqt.org"
-license=("GPL2")
+pkgdesc='The LXQt desktop panel'
+arch=('i686' 'x86_64')
+url='https://github.com/lxde/lxqt-panel'
+license=('GPL2')
# Since https://github.com/lxde/lxqt-panel/pull/281, liblxqt-git is necessary
depends=(
- "liblxqt-git"
- "kwindowsystem" "kguiaddons" "solid" "lxqt-globalkeys"
- "menu-cache" "libxcomposite" "lxmenu-data" "libdbusmenu-qt5"
+ "kwindowsystem" "kguiaddons" "solid"
+ "menu-cache" "libxcomposite" "lxmenu-data" "libdbusmenu-qt5"
+ "liblxqt-git" "lxqt-globalkeys"
)
optdepends=(
- "alsa-lib: Recompile for Alsa support in volume control plugin"
- "libpulse: Recompile for PulseAudio support in volume control plugin"
- "lm_sensors: Recompile for Sensors (battery) plugin"
- "libstatgrab: Recompile for network and CPU monitor plugin"
+ "alsa-lib: Recompile for Alsa support in volume control plugin"
+ "libpulse: Recompile for PulseAudio support in volume control plugin"
+ "lm_sensors: Recompile for Sensors (battery) plugin"
+ "libstatgrab: Recompile for network and CPU monitor plugin"
)
makedepends=("git" "cmake" "qt5-tools")
provides=("$_pkgname")
@@ -26,23 +28,22 @@ conflicts=("$_pkgname")
source=("git+https://github.com/lxde/$_pkgname.git")
sha256sums=('SKIP')
-
pkgver() {
- cd "$srcdir/$_pkgname"
- git describe --always | sed "s/-/./g"
+ cd "$srcdir/$_pkgname"
+ git describe --always | sed "s/-/./g"
}
build() {
- mkdir -p build
- cd build
- cmake "$srcdir/$_pkgname" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=/usr/lib \
- -DSYSSTAT_PLUGIN=No
- make
+ mkdir -p build
+ cd build
+ cmake "$srcdir/$_pkgname" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib \
+ -DSYSSTAT_PLUGIN=No
+ make
}
package() {
- cd build
- make DESTDIR="$pkgdir" install
+ cd build
+ make DESTDIR="$pkgdir" install
}