summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJerome Leclanche2015-06-09 22:00:48 +0200
committerJerome Leclanche2015-06-09 22:00:48 +0200
commitb2165b2efc46e11b09ba07cb22dfdd8911c682a6 (patch)
tree7c74defe98a7723980a31ae11a73e052c01ef369
downloadaur-b2165b2efc46e11b09ba07cb22dfdd8911c682a6.tar.gz
Initial import from old AUR
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD46
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f7bbc0ce5ee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = lxqt-panel-git
+ pkgdesc = The LXQt desktop panel
+ pkgver = 0.9.0.155.gbc4d32b
+ pkgrel = 1
+ url = http://lxqt.org
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = cmake
+ makedepends = qt5-tools
+ depends = kwindowsystem
+ depends = kguiaddons
+ depends = solid
+ depends = lxqt-globalkeys
+ depends = menu-cache
+ depends = libxcomposite
+ depends = lxmenu-data
+ optdepends = alsa-lib: Recompile for Alsa support in volume control plugin
+ optdepends = libpulse: Recompile for PulseAudio support in volume control plugin
+ optdepends = lm_sensors: Recompile for Sensors (battery) plugin
+ optdepends = libstatgrab: Recompile for network and CPU monitor plugin
+ optdepends = libsysstat: Recompile for network and CPU monitor plugin
+ provides = lxqt-panel
+ conflicts = lxqt-panel
+ source = git+https://github.com/lxde/lxqt-panel.git
+ sha256sums = SKIP
+
+pkgname = lxqt-panel-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ccb22a38eaa3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Jerome Leclanche <jerome@leclan.ch>
+
+_pkgname=lxqt-panel
+pkgname=$_pkgname-git
+pkgver=0.9.0.155.gbc4d32b
+pkgrel=1
+pkgdesc="The LXQt desktop panel"
+arch=("i686" "x86_64")
+url="http://lxqt.org"
+license=("GPL2")
+depends=(
+ "kwindowsystem" "kguiaddons" "solid" "lxqt-globalkeys"
+ "menu-cache" "libxcomposite" "lxmenu-data"
+)
+optdepends=(
+ "alsa-lib: Recompile for Alsa support in volume control plugin"
+ "libpulse: Recompile for PulseAudio support in volume control plugin"
+ "lm_sensors: Recompile for Sensors (battery) plugin"
+ "libstatgrab: Recompile for network and CPU monitor plugin"
+ "libsysstat: Recompile for network and CPU monitor plugin"
+)
+makedepends=("git" "cmake" "qt5-tools")
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+https://github.com/lxde/$_pkgname.git")
+sha256sums=("SKIP")
+
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --always | sed "s/-/./g"
+}
+
+build() {
+ mkdir -p build
+ cd build
+ cmake "$srcdir/$_pkgname" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}