summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Mattern2016-09-21 01:19:56 +0200
committerPeter Mattern2016-09-21 01:19:56 +0200
commitc8f92e49b6384882a41a1402ac6275d16bb31dca (patch)
tree5ca777bda7ded145be808ba11cbdeea747f7a10f
parent706b7b868777c6936ca51f127c3901899274307f (diff)
downloadaur-c8f92e49b6384882a41a1402ac6275d16bb31dca.tar.gz
Reflect upstream dependency changes
Choosing panel plugins or features by (not) providing dependencies was abandoned in 1c22479. Rather, all available plugins and features are built by default which can be toggled by CMake variables. Considering the nature of VCS packages this package will not change the defaults and hence has to state all dependencies in question.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD17
2 files changed, 12 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab32c6cbcf78..f0b244734ee3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Sep 20 23:00:23 UTC 2016
+# Tue Sep 20 23:19:37 UTC 2016
pkgbase = lxqt-panel-git
pkgdesc = The LXQt desktop panel
- pkgver = 0.10.0.129.g1c48664
+ pkgver = 0.10.0.143.g1c22479
pkgrel = 1
url = https://github.com/lxde/lxqt-panel
arch = i686
@@ -11,19 +11,18 @@ pkgbase = lxqt-panel-git
makedepends = git
makedepends = cmake
makedepends = qt5-tools
- depends = kwindowsystem
+ depends = alsa-lib
+ depends = libpulse
+ depends = lm_sensors
+ depends = libstatgrab
+ depends = libsysstat-git
depends = kguiaddons
depends = solid
depends = menu-cache
depends = libxcomposite
depends = lxmenu-data
depends = libdbusmenu-qt5
- depends = liblxqt-git
depends = lxqt-globalkeys
- optdepends = alsa-lib: Recompile for Alsa support in volume control plugin
- optdepends = libpulse: Recompile for PulseAudio support in volume control plugin
- optdepends = lm_sensors: Recompile for Sensors (battery) plugin
- optdepends = libstatgrab: Recompile for network and CPU monitor plugin
provides = lxqt-panel
conflicts = lxqt-panel
source = git+https://github.com/lxde/lxqt-panel.git
diff --git a/PKGBUILD b/PKGBUILD
index bd3ae14c5dab..ed7956a39725 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,23 +4,17 @@
_pkgname=lxqt-panel
pkgname=$_pkgname-git
-pkgver=0.10.0.129.g1c48664
+pkgver=0.10.0.143.g1c22479
pkgrel=1
pkgdesc='The LXQt desktop panel'
arch=('i686' 'x86_64')
url='https://github.com/lxde/lxqt-panel'
license=('GPL2')
-# Since https://github.com/lxde/lxqt-panel/pull/281, liblxqt-git is necessary
depends=(
- "kwindowsystem" "kguiaddons" "solid"
+ "alsa-lib" "libpulse" "lm_sensors" "libstatgrab" "libsysstat-git"
+ "kguiaddons" "solid"
"menu-cache" "libxcomposite" "lxmenu-data" "libdbusmenu-qt5"
- "liblxqt-git" "lxqt-globalkeys"
-)
-optdepends=(
- "alsa-lib: Recompile for Alsa support in volume control plugin"
- "libpulse: Recompile for PulseAudio support in volume control plugin"
- "lm_sensors: Recompile for Sensors (battery) plugin"
- "libstatgrab: Recompile for network and CPU monitor plugin"
+ "lxqt-globalkeys"
)
makedepends=("git" "cmake" "qt5-tools")
provides=("$_pkgname")
@@ -38,8 +32,7 @@ build() {
cd build
cmake "$srcdir/$_pkgname" \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=/usr/lib \
- -DSYSSTAT_PLUGIN=No
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib
make
}