summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFaerbit2015-09-12 00:37:11 +0200
committerFaerbit2015-09-12 00:37:11 +0200
commit4b15b80f4dd3da0787854fe6ecd3cb174f1fd7d1 (patch)
tree031972c510f74af8136e8e64d1228444d8b21b7e
downloadaur-4b15b80f4dd3da0787854fe6ecd3cb174f1fd7d1.tar.gz
Created package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bd8dfdfffb3f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = lxqt_wallet
+ pkgdesc = Secure storage of information for lxqt
+ pkgver = 2.1.0
+ pkgrel = 1
+ url = https://github.com/mhogomchungu/lxqt_wallet
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = cmake
+ makedepends = qt4
+ depends = libgcrypt
+ source = https://github.com/mhogomchungu/lxqt_wallet/releases/download/2.1.0/lxqt_wallet-2.1.0.tar.xz
+ sha256sums = 2ea48986791d71bec488356afb6beb8c2d3efd4032cfc63fdc91a192f64d3fb2
+
+pkgname = lxqt_wallet
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1556d0efa6d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+#Maintainer: Faerbit <faerbit at gmail dot com>
+
+pkgname=lxqt_wallet
+pkgver=2.1.0
+pkgrel=1
+pkgdesc="Secure storage of information for lxqt"
+arch=("i686" "x86_64")
+url="https://github.com/mhogomchungu/lxqt_wallet"
+license=("BSD")
+depends=("libgcrypt")
+makedepends=("cmake" "qt4")
+source=("https://github.com/mhogomchungu/lxqt_wallet/releases/download/${pkgver}/lxqt_wallet-${pkgver}.tar.xz")
+sha256sums=('2ea48986791d71bec488356afb6beb8c2d3efd4032cfc63fdc91a192f64d3fb2')
+
+build() {
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=RELEASE -DNOKDESUPPORT=true -DNOSECRETSUPPORT=true "$srcdir/$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+ install -D "$srcdir/$pkgname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}