summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsteffeno2024-05-12 21:39:31 +0200
committersteffeno2024-05-12 21:39:31 +0200
commit36441c49d7719f642e587e75403e20e809927f7c (patch)
treea3ba75b1a9d16f831e4b6e821300231d5c075f84
parentf5f033d0a565445ad12b378b0c1811eaa8db3a22 (diff)
downloadaur-36441c49d7719f642e587e75403e20e809927f7c.tar.gz
switched to build.zig, `DESTDIR` and `NAME` being not configurable required manual implementation of `zig build installsystemd`
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD26
2 files changed, 17 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0abe8f70a76..c4c1c184f446 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ly-git
pkgdesc = TUI display manager
- pkgver = 0.6.0.r4.g4ee2b3e
+ pkgver = 0.6.0.r9.g7506d6a
pkgrel = 1
url = https://github.com/fairyglade/ly
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 5778617f042b..c710a67f2daf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: steffeno <steffeno dash etc at protonmail dot com>
_pkgname=ly
pkgname="$_pkgname"-git
-pkgver=0.6.0.r4.g4ee2b3e
+pkgver=0.6.0.r9.g7506d6a
pkgrel=1
pkgdesc="TUI display manager"
arch=(i686 x86_64 aarch64)
@@ -21,18 +21,24 @@ pkgver() {
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd "$_pkgname"
- git submodule update --init --recursive
-}
-
build() {
- make -C "$_pkgname"
+ cd "$_pkgname"
+ zig build
}
package() {
cd "$_pkgname"
- make DESTDIR="$pkgdir" NAME=ly-dm install installsystemd
- sed -i "s;/usr/bin/ly;/usr/bin/ly-dm;g" "$pkgdir/usr/lib/systemd/system/ly.service"
- install -D -m644 license.md "${pkgdir}/usr/share/licenses/${pkgname}/WTFPL"
+ install -dZ "$pkgdir/etc/ly"
+ install -DZ zig-out/bin/ly -T "$pkgdir"/usr/bin/ly-dm
+ install -DZ res/config.ini -t "$pkgdir"/etc/ly
+ install -DZ res/xsetup.sh -t "$pkgdir"/etc/ly
+ install -DZ res/wsetup.sh -t "$pkgdir"/etc/ly
+ install -dZ "$pkgdir"/etc/ly/lang
+ install -DZ res/lang/* -t "$pkgdir"/etc/ly/lang
+ install -DZ -m644 res/pam.d/ly -t "$pkgdir"/etc/pam.d
+
+ install -dZ "$pkgdir"/usr/lib/systemd/system
+ install -DZ -m644 res/ly.service -t "$pkgdir"/usr/lib/systemd/system
+ sed -i 's;/usr/bin/ly;/usr/bin/ly-dm;g' "$pkgdir"/usr/lib/systemd/system/ly.service
+ install -DZ -m644 license.md -T "$pkgdir"/usr/share/licenses/"$pkgname"/WTFPL
}