summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsteffeno2023-03-24 19:04:29 +0100
committersteffeno2023-03-24 19:04:29 +0100
commita27450dd1f197f6888e8a1e0962de6ebaa1339c2 (patch)
treeddfb9ecdde79dfc6f30c93b08e5faf924b5b9879
parent2892dac7acd6cfb8c009c3cc77d62b01d3bac2ae (diff)
downloadaur-a27450dd1f197f6888e8a1e0962de6ebaa1339c2.tar.gz
project moved: changed source
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 22 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 47c39a1fb0eb..74c6bcd8be91 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,23 @@
pkgbase = ly-git
pkgdesc = TUI display manager
- pkgver = 0.5.3.r82.g5db09ce
+ pkgver = 0.5.3.r89.gc64f806
pkgrel = 1
- url = https://github.com/nullgemm/ly
+ url = https://github.com/fairyglade/ly
arch = i686
arch = x86_64
arch = aarch64
license = custom:WTFPL
makedepends = git
+ makedepends = libxcb
depends = pam
- depends = xorg-xauth
+ optdepends = xorg-xauth: for X server sessions
+ provides = ly
conflicts = ly
- conflicts = python-ly-git
+ conflicts = python-ly
backup = etc/ly/config.ini
- source = git+https://github.com/nullgemm/ly.git
+ backup = etc/ly/wsetup.sh
+ backup = etc/ly/xsetup.sh
+ source = git+https://github.com/fairyglade/ly.git
md5sums = SKIP
pkgname = ly-git
diff --git a/PKGBUILD b/PKGBUILD
index 5927984daac7..7624d29372af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,19 @@
# Maintainer: steffeno <steffeno dash etc at protonmail dot com>
-pkgname=ly-git
-pkgver=0.5.3.r82.g5db09ce
+_pkgname=ly
+pkgname="$_pkgname"-git
+pkgver=0.5.3.r89.gc64f806
pkgrel=1
pkgdesc="TUI display manager"
-arch=('i686' 'x86_64' 'aarch64')
-url="https://github.com/nullgemm/ly"
+arch=(i686 x86_64 aarch64)
+url="https://github.com/fairyglade/$_pkgname"
license=('custom:WTFPL')
-makedepends=('git')
-depends=('pam' 'xorg-xauth')
-conflicts=('ly' 'python-ly-git')
-backup=('etc/ly/config.ini')
-source=('git+https://github.com/nullgemm/ly.git')
+depends=(pam)
+makedepends=(git libxcb)
+optdepends=('xorg-xauth: for X server sessions')
+conflicts=(ly python-ly)
+provides=(ly)
+backup=(etc/"$_pkgname"/{config.ini,wsetup.sh,xsetup.sh})
+source=("git+$url.git")
md5sums=('SKIP')
pkgver() {
@@ -20,7 +23,7 @@ pkgver() {
prepare() {
cd ly
- git submodule update --init --recursive
+ git submodule update --init --recursive
}
build() {