summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcylgom2018-09-23 19:13:19 +0000
committercylgom2018-09-23 19:13:19 +0000
commita3b305359485ae75352b3f1cb75c277651c9ac27 (patch)
treea2e3947d32e77d41625e8637c65b934cb9d92903
parent6552d19b75c458dacadafd798a3f6afc9dfca19f (diff)
downloadaur-a3b305359485ae75352b3f1cb75c277651c9ac27.tar.gz
updated for submodules and version tracking support
-rw-r--r--PKGBUILD20
1 files changed, 16 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b8d3e063abf5..dee8e84d4915 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,27 @@
# Maintainer: cylgom <cylgom@gmail.com>
pkgname=ly-git
-pkgver=0.0.1
+pkgver=0.2
pkgrel=1
pkgdesc="ncurses display manager"
arch=('i686' 'x86_64')
url="https://github.com/cylgom/ly"
license=('custom:WTFPL')
makedepends=('git')
-depends=('pam' 'ncurses' 'libx11' 'xorg-xinit' 'xorg-xauth')
-source=('git+https://github.com/cylgom/ly.git')
-md5sums=('SKIP')
+depends=('pam' 'xorg-xinit' 'xorg-xauth')
+source=('git+https://github.com/cylgom/ly.git'
+ 'git+https://github.com/cylgom/termbox-next.git'
+ 'git+https://github.com/benhoyt/inih.git')
+md5sums=('SKIP' 'SKIP' 'SKIP')
+
+pkgver() {
+ cd ly
+ git describe --tags
+}
+
+prepare() {
+ cd ly
+ git submodule update --init --recursive
+}
build() {
cd ly