summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFanch2018-11-28 14:31:30 +0100
committerFanch2018-11-28 14:31:30 +0100
commit4f33c6c044f37e7a8d4779d67cad7816f66f87f5 (patch)
treef79f752bb622551fa2be2b29f24441458afb93e4
parent838894d22f3266ee5fae6909c26aca34269bc8d0 (diff)
downloadaur-4f33c6c044f37e7a8d4779d67cad7816f66f87f5.tar.gz
Update Version
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD33
2 files changed, 20 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c43656cd1e0..d503f4c310a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = lychee
pkgdesc = Lychee is an easy to use and great looking photo-management-system.
- pkgver = 3.1.4
+ pkgver = 3.1.6
pkgrel = 1
url = http://lychee.electerious.com/
arch = any
license = MIT
+ depends = php
+ depends = php-gd
+ depends = mariadb
optdepends = php-apache: to use the Apache web server
- optdepends = php-sqlite: to use the SQLite database backend
- optdepends = php-pgsql: to use the PostgreSQL database backend
- optdepends = mariadb: to use the MySQL database backend
options = !strip
+ options = emptydirs
backup = etc/webapps/lychee/apache.example.conf
- source = lychee-3.1.4.tar.gz::https://github.com//electerious/Lychee/archive/v3.1.4.tar.gz
+ source = lychee-3.1.6.tar.gz::https://github.com/electerious/Lychee/archive/v3.1.6.tar.gz
source = apache.example.conf
- sha256sums = 501d1ebf21b868660e128882aa992449e77bc460682d038a8e5e616af502c8c8
+ sha256sums = 721087e3b451300445f3845d39e5921541ea0a8e7ab0462a2ea24942869ab1b1
sha256sums = fe1400a1be9b60c4c8b6759b588638536188a73307cd061789877cd5fd491557
pkgname = lychee
diff --git a/PKGBUILD b/PKGBUILD
index 652785cf2783..361f0c323e16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,28 @@
-# Maintainer: Sonic-Y3k <sonic.y3k@googlemail.com>
+
pkgname=lychee
-pkgver=3.1.4
+pkgver=3.1.6
pkgrel=1
pkgdesc="Lychee is an easy to use and great looking photo-management-system."
arch=('any')
url="http://lychee.electerious.com/"
license=('MIT')
-#depends=('exif' 'php-gd')
-optdepends=('php-apache: to use the Apache web server'
- 'php-sqlite: to use the SQLite database backend'
- 'php-pgsql: to use the PostgreSQL database backend'
- 'mariadb: to use the MySQL database backend')
+depends=('php' 'php-gd' 'mariadb')
+optdepends=('php-apache: to use the Apache web server')
makedepends=()
-options=('!strip')
+options=('!strip' emptydirs)
backup=('etc/webapps/lychee/apache.example.conf')
-source=("$pkgname-$pkgver.tar.gz::https://github.com//electerious/Lychee/archive/v$pkgver.tar.gz"
+source=("$pkgname-$pkgver.tar.gz::https://github.com/electerious/Lychee/archive/v$pkgver.tar.gz"
'apache.example.conf')
-sha256sums=('501d1ebf21b868660e128882aa992449e77bc460682d038a8e5e616af502c8c8'
- 'fe1400a1be9b60c4c8b6759b588638536188a73307cd061789877cd5fd491557')
-
-prepare() {
- cd $srcdir/Lychee-$pkgver
- find . -type f -name .gitattributes -delete
- find . -type f -name .gitkeep -delete
- find . -type f -name .gitignore -delete
- find . -type f -name .gitmodules -delete
- find . -type f -name .travis.yml -delete
- find . -type d -name .git -exec rm -rf {} \;
+sha256sums=('721087e3b451300445f3845d39e5921541ea0a8e7ab0462a2ea24942869ab1b1'
+ 'fe1400a1be9b60c4c8b6759b588638536188a73307cd061789877cd5fd491557')
+
+pkgver() {
+ curl -Is https://github.com/electerious/Lychee/releases/latest | awk -F'/' '/^Location/ {print $NF}' | sed 's/v//' |sed 's/[^[:print:]]//'
+
}
+
package() {
# install project
install -d ${pkgdir}/usr/share/webapps/