summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSonic-Y3k2015-09-02 00:18:27 +0200
committerSonic-Y3k2015-09-02 00:18:27 +0200
commitda94a5a34454ce0f248378e649810fed6666007a (patch)
tree0b4bffc57a046bce467249063b784b278a8f639f
downloadaur-da94a5a34454ce0f248378e649810fed6666007a.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD47
-rw-r--r--apache.example.conf18
3 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..37633dff9eab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = lychee
+ pkgdesc = Lychee is an easy to use and great looking photo-management-system.
+ pkgver = 3.0.5
+ pkgrel = 1
+ url = http://lychee.electerious.com/
+ arch = any
+ license = MIT
+ optdepends = php-apache: to use the Apache web server
+ optdepends = php-sqlite: to use the SQLite database backend
+ optdepends = php-pgsql: to use the PostgreSQL database backend
+ optdepends = mariadb: to use the MySQL database backend
+ options = !strip
+ backup = etc/webapps/lychee/apache.example.conf
+ source = lychee-3.0.5.tar.gz::https://github.com//electerious/Lychee/archive/v3.0.5.tar.gz
+ source = apache.example.conf
+ sha256sums = e0b6065da52fae14852236291e0e4930e5becfa2109aa8c8d56f380dde79ff44
+ sha256sums = fe1400a1be9b60c4c8b6759b588638536188a73307cd061789877cd5fd491557
+
+pkgname = lychee
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..36cb87ede6eb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Sonic-Y3k <sonic.y3k@googlemail.com>
+
+pkgname=lychee
+pkgver=3.0.5
+pkgrel=1
+pkgdesc="Lychee is an easy to use and great looking photo-management-system."
+arch=('any')
+url="http://lychee.electerious.com/"
+license=('MIT')
+#depends=('exif' 'php-gd')
+optdepends=('php-apache: to use the Apache web server'
+ 'php-sqlite: to use the SQLite database backend'
+ 'php-pgsql: to use the PostgreSQL database backend'
+ 'mariadb: to use the MySQL database backend')
+makedepends=()
+options=('!strip')
+backup=('etc/webapps/lychee/apache.example.conf')
+source=("$pkgname-$pkgver.tar.gz::https://github.com//electerious/Lychee/archive/v$pkgver.tar.gz"
+ 'apache.example.conf')
+sha256sums=('e0b6065da52fae14852236291e0e4930e5becfa2109aa8c8d56f380dde79ff44'
+ 'fe1400a1be9b60c4c8b6759b588638536188a73307cd061789877cd5fd491557')
+
+prepare() {
+ cd $srcdir/Lychee-$pkgver
+ find . -type f -name .gitattributes -delete
+ find . -type f -name .gitkeep -delete
+ find . -type f -name .gitignore -delete
+ find . -type f -name .gitmodules -delete
+ find . -type f -name .travis.yml -delete
+ find . -type d -name .git -exec rm -rf {} \;
+}
+
+package() {
+ # install project
+ install -d ${pkgdir}/usr/share/webapps/
+ cp -a ${srcdir}/Lychee-$pkgver ${pkgdir}/usr/share/webapps/${pkgname}
+
+ # install apache config file
+ install -d ${pkgdir}/etc/webapps/${pkgname}
+ install -m 644 ${srcdir}/apache.example.conf ${pkgdir}/etc/webapps/${pkgname}
+
+ find ${pkgdir}/usr/share/webapps/${pkgname} -type f -exec chmod 0644 {} \;
+ find ${pkgdir}/usr/share/webapps/${pkgname} -type d -exec chmod 0755 {} \;
+
+ chmod 777 ${pkgdir}/usr/share/webapps/${pkgname}/data
+ chmod 777 ${pkgdir}/usr/share/webapps/${pkgname}/uploads
+}
diff --git a/apache.example.conf b/apache.example.conf
new file mode 100644
index 000000000000..65e8179220cd
--- /dev/null
+++ b/apache.example.conf
@@ -0,0 +1,18 @@
+<IfModule mod_alias.c>
+ Alias /lychee /usr/share/webapps/lychee/
+</IfModule>
+
+<Directory /usr/share/webapps/lychee/>
+ Options FollowSymlinks
+ AllowOverride all
+ Require all granted
+ php_admin_value open_basedir "/srv/http/:/home/:/tmp/:/usr/share/pear/:/usr/share/webapps/lychee/:/etc/webapps/lychee"
+</Directory>
+
+<VirtualHost *:80>
+ ServerAdmin foo@foofarm.com
+ DocumentRoot /usr/share/webapps/lychee
+ ServerName lychee.foo.com
+ ErrorLog /var/log/httpd/lychee.foo.info-error_log
+ CustomLog /var/log/httpd/lychee.foo.info-access_log common
+</VirtualHost>