summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin2021-08-14 19:02:39 +0200
committerMarcin2021-08-14 20:31:37 +0200
commit7956f77740b850f181304dbfababac6d70d58575 (patch)
treeb4853c7604d158b3e1214820b38d16ec6072e8f6
downloadaur-7956f77740b850f181304dbfababac6d70d58575.tar.gz
first release: 3.3.2
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD20
-rw-r--r--lycheeslicer.install25
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c4a4687ed55
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = lycheeslicer
+ pkgdesc = Lychee Slicer
+ pkgver = 3.3.2
+ pkgrel = 1
+ url = http://mango3d.io
+ install = lycheeslicer.install
+ arch = x86_64
+ groups =
+ license =
+ depends = gtk3
+ depends = libsecret
+ depends = libnotify
+ depends = nss
+ depends = libxss
+ depends = libxtst
+ depends = xdg-utils
+ depends = at-spi2-atk
+ depends = at-spi2-core
+ depends = libappindicator-gtk3
+ options = !strip
+ options = !emptydirs
+ source_x86_64 = https://mango-lychee.nyc3.cdn.digitaloceanspaces.com/LycheeSlicer-3.3.2.deb
+ sha512sums_x86_64 = 1fc494fa948290e83a89be3c29b0cdb5158daff7e8c46a5641155bc5eb028c0c31b5f5ec51abb4939ef02b791780ca4d7e7e095e90c286fb1d295373f81282d6
+
+pkgname = lycheeslicer
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b25bd403042f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Generated by debtap
+# Maintainer: LycheeSlicer
+# Contributor: LycheeSlicer
+pkgname=lycheeslicer
+pkgver=3.3.2
+pkgrel=1
+pkgdesc="Lychee Slicer"
+arch=('x86_64')
+url="http://mango3d.io"
+license=('')
+groups=('')
+depends=('gtk3' 'libsecret' 'libnotify' 'nss' 'libxss' 'libxtst' 'xdg-utils' 'at-spi2-atk' 'at-spi2-core' 'libappindicator-gtk3')
+options=('!strip' '!emptydirs')
+install=${pkgname}.install
+source_x86_64=("https://mango-lychee.nyc3.cdn.digitaloceanspaces.com/LycheeSlicer-$pkgver.deb")
+sha512sums_x86_64=('1fc494fa948290e83a89be3c29b0cdb5158daff7e8c46a5641155bc5eb028c0c31b5f5ec51abb4939ef02b791780ca4d7e7e095e90c286fb1d295373f81282d6')
+package(){
+ # Extract package data
+ tar xf data.tar.xz -C "${pkgdir}"
+}
diff --git a/lycheeslicer.install b/lycheeslicer.install
new file mode 100644
index 000000000000..ebb3904ad693
--- /dev/null
+++ b/lycheeslicer.install
@@ -0,0 +1,25 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+
+ # Link to the binary
+ ln -sf '/opt/LycheeSlicer/lycheeslicer' '/usr/bin/lycheeslicer'
+
+ # SUID chrome-sandbox for Electron 5+
+ chmod 4755 '/opt/LycheeSlicer/chrome-sandbox' || true
+
+ update-mime-database /usr/share/mime || true
+ update-desktop-database /usr/share/applications || true
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+
+ # Delete the link to the binary
+ rm -f '/usr/bin/lycheeslicer'
+ update-desktop-database -q
+}