summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspecialworld832015-09-30 13:30:33 +0200
committerspecialworld832015-09-30 13:30:33 +0200
commitafcc50a3fc6ca5d1c2e7b05dcf313fe0509d305b (patch)
tree8c7300e7f3667720a2cf96d2a1a90bd99f152d36
downloadaur-afcc50a3fc6ca5d1c2e7b05dcf313fe0509d305b.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rwxr-xr-xPKGBUILD40
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..603144020950
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = lylibrary
+ pkgdesc = LyLibrary provides everything necessary to the books cataloguing, the loans management and the registration of the library readers.
+ pkgver = 2.1.1
+ pkgrel = 1
+ url = http://www.codelinsoft.it/sito/2013-11-17-17-56-34/lylibrary.html#
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ depends = qt4
+ depends = mysql
+ depends = qca-ossl
+ source = http://www.codelinsoft.it/sito/download/categoria-linux/LyLibrary/lylibrary-sorgentesource.raw
+ md5sums = 4d6663c7e675b282219673565f290ce3
+
+pkgname = lylibrary
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..9240a8885a0d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Contributor: Calogero e Angelo ScarnĂ  <info@codelinsoft.it>
+pkgname=lylibrary
+pkgver=2.1.1
+pkgrel=1
+pkgdesc="LyLibrary provides everything necessary to the books cataloguing, the loans management and the registration of the library readers."
+url="http://www.codelinsoft.it/sito/2013-11-17-17-56-34/lylibrary.html#"
+arch=('i686' 'x86_64')
+depends=('qt4' 'mysql' 'qca-ossl')
+license=(LGPL)
+source=(http://www.codelinsoft.it/sito/download/categoria-linux/LyLibrary/lylibrary-sorgentesource.raw)
+md5sums=("4d6663c7e675b282219673565f290ce3")
+
+
+
+build() {
+cd "${srcdir}/${pkgname}-${pkgver}"
+qmake-qt4
+make -j5
+}
+
+package() {
+cd "${srcdir}/${pkgname}-${pkgver}"
+install -d "$pkgdir"/opt
+install -dm 755 ${pkgdir}/opt/lylibrary
+cp -rv "${srcdir}/${pkgname}-${pkgver}/lylibrary/lylibrary" "${pkgdir}/opt/lylibrary"
+cp -rv "${srcdir}/${pkgname}-${pkgver}/lylibrary/images/logo4.png" "${pkgdir}/opt/lylibrary/"
+install -m 755 -d "${pkgdir}/opt/lylibrary/plugin"
+install -m 755 -d "${pkgdir}/opt/lylibrary/data"
+cp -rv "${srcdir}/${pkgname}-${pkgver}/lylibrary/data/" "${pkgdir}/opt/lylibrary/"
+
+install -Dm644 "${srcdir}/${pkgname}-${pkgver}/lylibrary/desktop/lylibrary.desktop" "${pkgdir}/usr/share/applications/lylibrary.desktop"
+
+cp -rv "${srcdir}/${pkgname}-${pkgver}/lylibrary/plugin/" "${pkgdir}/opt/lylibrary/"
+
+
+
+
+
+}
+