summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2019-03-30 16:41:57 -0400
committerJean Lucas2019-03-30 16:41:57 -0400
commitf8ebd3fe7a8b514df08a39f3d794990b35429a1f (patch)
tree0a89ff0b939e5d3c218bb858c871ee94e5a6d61d
downloadaur-f8ebd3fe7a8b514df08a39f3d794990b35429a1f.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD32
-rw-r--r--setup.py71
3 files changed, 125 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eee7f0dd437d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Sat Mar 30 20:41:20 UTC 2019
+pkgbase = lynda-dl-git
+ pkgdesc = Tool to download courses from Lynda (git)
+ pkgver = 0.3+3+gafa9782
+ pkgrel = 1
+ url = https://github.com/r0oth3x49/lynda-dl
+ arch = any
+ license = MIT
+ depends = python-requests
+ depends = python-six
+ depends = python-colorama
+ depends = python-unidecode
+ depends = python-pyopenssl
+ conflicts = lynda-dl
+ source = git+https://github.com/r0oth3x49/lynda-dl
+ source = setup.py
+ sha512sums = SKIP
+ sha512sums = 3e76a6678bf00708437fab400ded30d2169a88180ea77d51badecba14ba7649645791500e7d0649be15c25f7980c6d17f8f3a3a4bbf65782dac29556266ec6ee
+
+pkgname = lynda-dl-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c93b12112bd7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Jean Lucas <jean@4ray.co>
+
+pkgname=lynda-dl-git
+pkgver=0.3+3+gafa9782
+pkgrel=1
+pkgdesc='Tool to download courses from Lynda (git)'
+arch=(any)
+url=https://github.com/r0oth3x49/lynda-dl
+license=(MIT)
+depends=(python-requests
+ python-six
+ python-colorama
+ python-unidecode
+ python-pyopenssl)
+conflicts=(lynda-dl)
+source=(git+$url
+ setup.py)
+sha512sums=('SKIP'
+ '3e76a6678bf00708437fab400ded30d2169a88180ea77d51badecba14ba7649645791500e7d0649be15c25f7980c6d17f8f3a3a4bbf65782dac29556266ec6ee')
+
+pkgver() {
+ cd lynda-dl
+ git describe --tags | sed 's/v//;s/-/+/g'
+}
+
+package() {
+ cd lynda-dl
+ cp ../setup.py .
+ mv lynda-dl.py lynda/lynda_dl.py
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm 644 LICENSE "$pkgdir"/usr/share/licenses/lynda-dl/LICENSE
+}
diff --git a/setup.py b/setup.py
new file mode 100644
index 000000000000..0539e19b7320
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,71 @@
+# -*- coding: utf-8 -*-
+#
+# you can install this to a local test virtualenv like so:
+# virtualenv venv
+# ./venv/bin/pip install --editable .
+# ./venv/bin/pip install --editable .[dev] # with dev requirements, too
+
+from setuptools import setup
+
+from lynda import __version__
+
+
+def read_file(filename, alt=None):
+ """
+ Read the contents of filename or give an alternative result instead.
+ """
+ lines = None
+
+ try:
+ with open(filename) as f:
+ lines = f.read()
+ except IOError:
+ lines = [] if alt is None else alt
+ return lines
+
+
+requirements = read_file('requirements.txt')
+
+trove_classifiers = [
+ 'Development Status :: 4 - Beta',
+ 'Environment :: Console',
+ 'Intended Audience :: End Users/Desktop',
+ 'License :: OSI Approved :: MIT License',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: Implementation :: CPython',
+ 'Programming Language :: Python :: Implementation :: PyPy',
+ 'Programming Language :: Python',
+ 'Topic :: Education',
+]
+
+setup(
+ name='lynda-dl',
+ version=__version__,
+ maintainer='Nasir Khan',
+ maintainer_email='r0oth3x49@gmail.com',
+
+ license='MIT',
+ url='https://github.com/r0oth3x49/lynda-dl',
+
+ install_requires=requirements,
+
+ description='A cross-platform python based utility to download courses from lynda for personal offline use.',
+ keywords=['lynda-dl','lynda', 'download', 'education', 'video'],
+ classifiers=trove_classifiers,
+
+ packages=["lynda", "lynda._colorized"],
+ entry_points=dict(
+ console_scripts=[
+ 'lynda-dl=lynda.lynda_dl:main'
+ ]
+ ),
+
+ platforms=['any'],
+)