summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranthraxx2016-08-11 16:36:43 +0200
committeranthraxx2016-08-11 16:36:43 +0200
commit88db758095cc52b8d8aa6e2d025bb357725f32c9 (patch)
tree7994907c2311718e7cc4999437fcddb7cd3d92c3
parentf08ef6dab828de2e7bd2ca11e575493581a7dd3e (diff)
downloadaur-88db758095cc52b8d8aa6e2d025bb357725f32c9.tar.gz
upgpkg: lynis-git 2.3.2.1414.ed4dd3b-1
- adding some optdepends - adding awk to depends - fixing new CHANGELOG file name
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD40
2 files changed, 25 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 90718e1b48ce..6de764af9551 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,18 @@
+# Generated by mksrcinfo v8
+# Thu Aug 11 14:36:43 UTC 2016
pkgbase = lynis-git
pkgdesc = Security and system auditing tool to harden Unix/Linux systems
- pkgver = 2.1.0.407.dfe5e80
+ pkgver = 2.3.2.1414.ed4dd3b
pkgrel = 1
url = http://cisofy.com/lynis/
arch = any
license = GPL3
makedepends = git
depends = sh
+ depends = awk
optdepends = net-tools: networking tests
+ optdepends = bind-tools: nameserver tests
+ optdepends = iptables: firewall tests
optdepends = bash-completion: completion for bash
provides = lynis
conflicts = lynis
diff --git a/PKGBUILD b/PKGBUILD
index c568fbad80b0..6c150a929a3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,18 @@
pkgname=lynis-git
_pkgname=lynis
-pkgver=2.1.0.407.dfe5e80
+pkgver=2.3.2.1414.ed4dd3b
pkgrel=1
pkgdesc='Security and system auditing tool to harden Unix/Linux systems'
url='http://cisofy.com/lynis/'
license=('GPL3')
arch=('any')
backup=('etc/lynis/default.prf')
-depends=('sh')
-optdepends=(
- 'net-tools: networking tests'
- 'bash-completion: completion for bash'
-)
+depends=('sh' 'awk')
+optdepends=('net-tools: networking tests'
+ 'bind-tools: nameserver tests'
+ 'iptables: firewall tests'
+ 'bash-completion: completion for bash')
makedepends=('git')
provides=('lynis')
conflicts=('lynis')
@@ -22,7 +22,8 @@ sha512sums=('SKIP')
pkgver() {
cd ${pkgname}
- printf "%s.%s.%s" "$(git describe --tags --abbrev=0)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "%s.%s.%s" "$(git describe --tags --abbrev=0)" \
+ "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
@@ -33,31 +34,28 @@ prepare() {
package() {
cd ${pkgname}
- # profile
- install -Dm 644 default.prf "${pkgdir}/etc/${_pkgname}/default.prf"
-
# binary
install -Dm 755 lynis "${pkgdir}/usr/bin/${_pkgname}"
+ # profile
+ install -Dm 644 default.prf "${pkgdir}/etc/${_pkgname}/default.prf"
+
# plugins, include, db
install -d "${pkgdir}/usr/share/${_pkgname}"
- cp -a db include plugins "${pkgdir}/usr/share/${_pkgname}"
+ cp -ra db include plugins "${pkgdir}/usr/share/${_pkgname}"
# doc files
- install -d "${pkgdir}/usr/share/doc/${pkgname}"
- install -m 644 -t "${pkgdir}/usr/share/doc/${pkgname}" README INSTALL CHANGELOG FAQ
- install -d "${pkgdir}/usr/share/licenses/${pkgname}"
- install -m 644 README "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-
- # manpage
- install -Dm 644 ${_pkgname}.8 "${pkgdir}/usr/share/man/man8/${_pkgname}.8"
+ install -Dm 644 README INSTALL CHANGELOG.md FAQ \
+ -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm 644 ${_pkgname}.8 -t "${pkgdir}/usr/share/man/man8"
# completion
- install -Dm 644 extras/bash_completion.d/${_pkgname} "${pkgdir}/usr/share/bash-completion/completions/${_pkgname}"
+ install -Dm 644 extras/bash_completion.d/${_pkgname} \
+ -t "${pkgdir}/usr/share/bash-completion/completions"
# systemd
- install -d "${pkgdir}/usr/lib/systemd/system/"
- install -m 644 extras/systemd/{lynis.service,lynis.timer} "${pkgdir}/usr/lib/systemd/system/"
+ install -Dm 644 extras/systemd/{lynis.service,lynis.timer} \
+ -t "${pkgdir}/usr/lib/systemd/system"
}
# vim:set ts=2 sw=2 ft=sh et: