summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranthraxx2015-06-18 18:01:28 +0200
committeranthraxx2015-06-18 18:01:28 +0200
commitf08ef6dab828de2e7bd2ca11e575493581a7dd3e (patch)
treef7622a7f191d1030cba3363c87341dd36a88e657
downloadaur-f08ef6dab828de2e7bd2ca11e575493581a7dd3e.tar.gz
addpkg: lynis-git 2.1.0.407.dfe5e80-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD63
2 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..90718e1b48ce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = lynis-git
+ pkgdesc = Security and system auditing tool to harden Unix/Linux systems
+ pkgver = 2.1.0.407.dfe5e80
+ pkgrel = 1
+ url = http://cisofy.com/lynis/
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = sh
+ optdepends = net-tools: networking tests
+ optdepends = bash-completion: completion for bash
+ provides = lynis
+ conflicts = lynis
+ backup = etc/lynis/default.prf
+ source = lynis-git::git+https://github.com/CISOfy/lynis
+ sha512sums = SKIP
+
+pkgname = lynis-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c568fbad80b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer: Levente Polyak <levente[at]leventepolyak[dot]net>
+
+pkgname=lynis-git
+_pkgname=lynis
+pkgver=2.1.0.407.dfe5e80
+pkgrel=1
+pkgdesc='Security and system auditing tool to harden Unix/Linux systems'
+url='http://cisofy.com/lynis/'
+license=('GPL3')
+arch=('any')
+backup=('etc/lynis/default.prf')
+depends=('sh')
+optdepends=(
+ 'net-tools: networking tests'
+ 'bash-completion: completion for bash'
+)
+makedepends=('git')
+provides=('lynis')
+conflicts=('lynis')
+source=(${pkgname}::git+https://github.com/CISOfy/${_pkgname})
+sha512sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ printf "%s.%s.%s" "$(git describe --tags --abbrev=0)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd ${pkgname}
+ sed -e 's|/path/to/lynis|/usr/bin/lynis|g' -i extras/systemd/lynis.service
+}
+
+package() {
+ cd ${pkgname}
+
+ # profile
+ install -Dm 644 default.prf "${pkgdir}/etc/${_pkgname}/default.prf"
+
+ # binary
+ install -Dm 755 lynis "${pkgdir}/usr/bin/${_pkgname}"
+
+ # plugins, include, db
+ install -d "${pkgdir}/usr/share/${_pkgname}"
+ cp -a db include plugins "${pkgdir}/usr/share/${_pkgname}"
+
+ # doc files
+ install -d "${pkgdir}/usr/share/doc/${pkgname}"
+ install -m 644 -t "${pkgdir}/usr/share/doc/${pkgname}" README INSTALL CHANGELOG FAQ
+ install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m 644 README "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ # manpage
+ install -Dm 644 ${_pkgname}.8 "${pkgdir}/usr/share/man/man8/${_pkgname}.8"
+
+ # completion
+ install -Dm 644 extras/bash_completion.d/${_pkgname} "${pkgdir}/usr/share/bash-completion/completions/${_pkgname}"
+
+ # systemd
+ install -d "${pkgdir}/usr/lib/systemd/system/"
+ install -m 644 extras/systemd/{lynis.service,lynis.timer} "${pkgdir}/usr/lib/systemd/system/"
+}
+
+# vim:set ts=2 sw=2 ft=sh et: