summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorD3S0X2020-08-13 20:20:04 +0200
committerD3S0X2020-08-13 20:20:04 +0200
commitf4dc506b6c2b94fcb4c427ef4f385e238595e8bf (patch)
treeb845fe8e77208e37162a37920c800c62eeb7db07
downloadaur-f4dc506b6c2b94fcb4c427ef4f385e238595e8bf.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD42
-rw-r--r--config.toml6
-rw-r--r--lyrebird.desktop11
4 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6ec65d0aaebe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = lyrebird
+ pkgdesc = Simple and powerful voice changer for Linux, written in GTK 3.
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/chxrlt/lyrebird
+ arch = any
+ license = MIT
+ depends = python>=3.8
+ depends = python-toml
+ depends = gtk3
+ optdepends = pavucontrol: audio support
+ provides = lyrebird
+ conflicts = lyrebird
+ source = https://github.com/chxrlt/lyrebird/archive/v1.0.1.tar.gz
+ source = lyrebird.desktop
+ source = config.toml
+ sha256sums = cf869cfd6b1237ad58ff8bd55fdf9f2032ba6d7159801395bec4a007245fd4ab
+ sha256sums = 912d5fbd57a0a1ea2a0f17bd41f9ddf687722c9c9ab88f51d3f33d3894417ca7
+ sha256sums = efe34e18fec84afca1bc64eaad4984125a35dfd55d1e8b604ede9186c6fda7e3
+
+pkgname = lyrebird
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bff0bc9e0d96
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Nico <desoxhd@gmail.com>
+pkgname=lyrebird
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="Simple and powerful voice changer for Linux, written in GTK 3."
+arch=('any')
+url="https://github.com/chxrlt/lyrebird"
+license=('MIT')
+depends=('python>=3.8' 'python-toml' 'gtk3')
+optdepends=('pavucontrol: audio support')
+conflicts=('lyrebird')
+provides=('lyrebird')
+
+source=("https://github.com/chxrlt/lyrebird/archive/v${pkgver}.tar.gz" "lyrebird.desktop" "config.toml")
+sha256sums=('cf869cfd6b1237ad58ff8bd55fdf9f2032ba6d7159801395bec4a007245fd4ab' '912d5fbd57a0a1ea2a0f17bd41f9ddf687722c9c9ab88f51d3f33d3894417ca7' 'efe34e18fec84afca1bc64eaad4984125a35dfd55d1e8b604ede9186c6fda7e3')
+
+package() {
+ BIN_PATH="$pkgdir/usr/lib/python3.8/site-packages/$pkgname"
+ CONFIG_PATH="$pkgdir/etc/$pkgname"
+
+ # create dirs
+ mkdir -p "$CONFIG_PATH"
+ mkdir -p "$BIN_PATH"
+
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # install config stuff
+ install -Dm 644 "$srcdir/config.toml" "$CONFIG_PATH/config.toml"
+ install -Dm 644 "presets.toml" "$CONFIG_PATH/presets.toml"
+
+ # install python package
+ cp -rf lyrebird "$BIN_PATH"
+ install -Dm 755 "app.py" "$BIN_PATH"
+ install -Dm 644 "icon.png" "$BIN_PATH/icon.png"
+
+ # workaround (why is this path hardcoded in mainwindow.py?)
+ install -Dm 644 "icon.png" "$pkgdir/usr/local/bin/$pkgname/icon.png"
+
+ # setup desktop entry
+ install -Dm 644 "icon.png" "$pkgdir/usr/share/pixmaps/lyrebird.png"
+ install -Dm 644 "$srcdir/lyrebird.desktop" "$pkgdir/usr/share/applications/lyrebird.desktop"
+}
diff --git a/config.toml b/config.toml
new file mode 100644
index 000000000000..5a473ea19948
--- /dev/null
+++ b/config.toml
@@ -0,0 +1,6 @@
+# Configuration file for Lyrebird
+# The following parameters are configurable
+# buffer_size = The buffer size to use for sox. Higher = better quality, at
+# the cost of higher latency. Default value is 1024
+[[config]]
+buffer_size = 1024
diff --git a/lyrebird.desktop b/lyrebird.desktop
new file mode 100644
index 000000000000..8e67baea9c74
--- /dev/null
+++ b/lyrebird.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Version=1.0
+Type=Application
+Name=Lyrebird
+GenericName=Voice Changer
+Icon=lyrebird
+Exec=python3 /usr/lib/python3.8/site-packages/lyrebird/app.py
+Path=/usr/lib/python3.8/site-packages/lyrebird/
+Terminal=false
+Categories=Audio;