summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-23 13:43:48 +0800
committerzxp198210052024-01-23 13:43:48 +0800
commit8bb18cc58812e47c220b277ffbc78164962b6143 (patch)
tree92bc2987aa9981de9f2e349945a3e07dff858649
downloadaur-8bb18cc58812e47c220b277ffbc78164962b6143.tar.gz
update to 0.1.0
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD41
-rw-r--r--lyrically.sh15
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c623698344b1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = lyrically-bin
+ pkgdesc = Music player inspired by Lyric Speaker
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/CyanSalt/lyrically
+ arch = x86_64
+ license = ISC
+ makedepends = gendesk
+ depends = electron28
+ source = lyrically-0.1.0.zip::https://github.com/CyanSalt/lyrically/releases/download/v0.1.0/Lyrically-linux-x64.zip
+ source = lyrically-0.1.0.png::https://raw.githubusercontent.com/CyanSalt/lyrically/v0.1.0/resources/images/icon.png
+ source = LICENSE-0.1.0::https://raw.githubusercontent.com/CyanSalt/lyrically/v0.1.0/LICENSE
+ source = lyrically.sh
+ sha256sums = 423c5e3763a68294fec232086f024ef5450df8880ac9cf01352d760bba78a214
+ sha256sums = ab219244090109bd4c111ee2f8d574337bc668860f9e9678190f4591df4dec1a
+ sha256sums = 9950b2ef9948d119f67c09e78478be5c96db2028bebf735ee60a9e3c5afe0bc0
+ sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
+
+pkgname = lyrically-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b2ec453c06b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=lyrically-bin
+_pkgname=Lyrically
+pkgver=0.1.0
+_electronversion=28
+pkgrel=1
+pkgdesc="Music player inspired by Lyric Speaker"
+arch=('x86_64')
+url="https://github.com/CyanSalt/lyrically"
+license=('ISC')
+conflits=("${pkgname%-bin}")
+depends=(
+ "electron${_electronversion}"
+)
+makedepends=(
+ 'gendesk'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.zip::${url}/releases/download/v${pkgver}/${_pkgname}-linux-x64.zip"
+ "${pkgname%-bin}-${pkgver}.png::https://raw.githubusercontent.com/CyanSalt/lyrically/v${pkgver}/resources/images/icon.png"
+ "LICENSE-${pkgver}::https://raw.githubusercontent.com/CyanSalt/lyrically/v${pkgver}/LICENSE"
+ "${pkgname%-bin}.sh"
+)
+sha256sums=('423c5e3763a68294fec232086f024ef5450df8880ac9cf01352d760bba78a214'
+ 'ab219244090109bd4c111ee2f8d574337bc668860f9e9678190f4591df4dec1a'
+ '9950b2ef9948d119f67c09e78478be5c96db2028bebf735ee60a9e3c5afe0bc0'
+ 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
+build() {
+ sed -e "s|@electronversion@|${_electronversion}|" \
+ -e "s|@appname@|${pkgname%-bin}|g" \
+ -e "s|@appasar@|app.asar|g" \
+ -i "${srcdir}/${pkgname%-bin}.sh"
+ gendesk -f -n -q --categories "AudioVideo" --name "${_pkgname}" --exec "${pkgname%-bin} %U"
+}
+package() {
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/${_pkgname}-linux-x64/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/${pkgname%-bin}-${pkgver}.png" "${pkgdir}/usr/share/pixmaps/${pkgname%-bin}.png"
+ install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 "${srcdir}/LICENSE-${pkgver}" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+} \ No newline at end of file
diff --git a/lyrically.sh b/lyrically.sh
new file mode 100644
index 000000000000..aacd8f895847
--- /dev/null
+++ b/lyrically.sh
@@ -0,0 +1,15 @@
+#!/bin/sh
+set -e
+_APPDIR="/usr/lib/@appname@"
+_ASAR="${_APPDIR}/@appasar@"
+export PATH="${_APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
+export ELECTRON_IS_DEV=0
+export NODE_ENV=production
+cd "${_APPDIR}"
+if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
+ exec electron@electronversion@ "${_ASAR}" "$@"
+else
+ exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
+fi
+exit \ No newline at end of file