summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBilal Elmoussaoui2017-01-06 03:09:03 +0100
committerBilal Elmoussaoui2017-01-06 03:09:03 +0100
commite788dcc91332a2c3a9b199782cbe7ac177896d9d (patch)
tree2be87ae889517612626ce1dc94d68c980b064c73
downloadaur-e788dcc91332a2c3a9b199782cbe7ac177896d9d.tar.gz
first release
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD47
-rw-r--r--lyricfier.desktop9
-rw-r--r--lyricfier.pngbin0 -> 41379 bytes
4 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..375284c0c0df
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = lyricfier
+ pkgdesc = a Spotify Lyrics alternative app
+ pkgver = 0.2.5
+ pkgrel = 1
+ url = https://github.com/emilioastarita/lyricfier
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = unzip
+ provides = temps
+ source = lyricfier.desktop
+ source = lyricfier.png
+ sha256sums = 2d5d757e286dbf32d75740ffe48e221ffdc2dc10f4fd3f1c5718d7f02fe127a5
+ sha256sums = 73393cdb03f498e5b43126323a6cf64bd529bd37182280f80bff25abc3a04297
+ source_i686 = https://github.com/emilioastarita/lyricfier/releases/download/0.2.5/lyricfier-linux-ia32.zip
+ sha256sums_i686 = e7c19ff3bf5d1d5b7875cbd15af8506868ef0defcda85efed07aa52faf4b5518
+ source_x86_64 = https://github.com/emilioastarita/lyricfier/releases/download/0.2.5/lyricfier-linux-x64.zip
+ sha256sums_x86_64 = c3bb633cc9f9b8fe258dc51c148eaec1e14eb58a301d78b8e190ca4230a2e073
+
+pkgname = lyricfier
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a5421b44f6b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Bilal ELmoussaoui <bil.elmoussaoui@gmail.com>
+
+pkgname=lyricfier
+_pkgbase=lyricfier
+pkgrel=1
+pkgver=0.2.5
+_pkgver=$pkgver
+pkgdesc="a Spotify Lyrics alternative app"
+url="https://github.com/emilioastarita/lyricfier"
+provides=('temps')
+arch=('i686' 'x86_64')
+license=('MIT')
+makedepends=('unzip')
+backup=()
+install=''
+source=(
+ "${_pkgbase}.desktop"
+ "${_pkgbase}.png"
+)
+
+source_i686+=("${url}/releases/download/${_pkgver}/${_pkgbase}-linux-ia32.zip")
+source_x86_64+=("${url}/releases/download/${_pkgver}/${_pkgbase}-linux-x64.zip")
+sha256sums_x86_64=('c3bb633cc9f9b8fe258dc51c148eaec1e14eb58a301d78b8e190ca4230a2e073')
+sha256sums_i686=('e7c19ff3bf5d1d5b7875cbd15af8506868ef0defcda85efed07aa52faf4b5518')
+sha256sums=(
+ '2d5d757e286dbf32d75740ffe48e221ffdc2dc10f4fd3f1c5718d7f02fe127a5'
+ '73393cdb03f498e5b43126323a6cf64bd529bd37182280f80bff25abc3a04297'
+ )
+
+package() {
+ install -D -m644 "./${_pkgbase}.desktop" "${pkgdir}/usr/share/applications/${_pkgbase}.desktop"
+ install -D -m644 "./${_pkgbase}.png" "${pkgdir}/usr/share/pixmaps/${_pkgbase}.png"
+ install -d "$pkgdir"/opt
+ cp -R "$srcdir"/ "$pkgdir"/opt/${_pkgbase}
+ install -d "$pkgdir"/usr/bin
+ ln -sf ../../opt/${_pkgbase}/${_pkgbase} "$pkgdir"/usr/bin/${_pkgbase}
+ rm -f "$pkgdir"/opt/${_pkgbase}/${_pkgbase}.png
+ rm -f "$pkgdir"/opt/${_pkgbase}/${_pkgbase}.desktop
+ case "$CARCH" in
+ i686)
+ rm -f "$pkgdir"/opt/${_pkgbase}/lyricfier-linux-ia32.zip
+ ;;
+ x86_64)
+ rm -f "$pkgdir"/opt/${_pkgbase}/lyricfier-linux-x64.zip
+ ;;
+ esac
+}
diff --git a/lyricfier.desktop b/lyricfier.desktop
new file mode 100644
index 000000000000..8f7831354bff
--- /dev/null
+++ b/lyricfier.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Lyricfier
+Comment=a Spotify Lyrics alternative app
+Exec=lyricfier
+Icon=lyricfier
+Terminal=false
+Type=Application
+StartupNotify=true
+Categories=Player;Audio;
diff --git a/lyricfier.png b/lyricfier.png
new file mode 100644
index 000000000000..c53c6b7e48f9
--- /dev/null
+++ b/lyricfier.png
Binary files differ