summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-09-14 17:58:59 +0800
committerzxp198210052023-09-14 17:58:59 +0800
commit30d0886e72d8234b8e2e1503f12a362b8686a0c6 (patch)
tree8ca596896ec0ea577cf83cd27fed9792b0522df1
parenteebd3fff66495ed4227f16bd1017888dabc5f981 (diff)
downloadaur-30d0886e72d8234b8e2e1503f12a362b8686a0c6.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--lyricistant.sh2
3 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3daec52dfb6f..2980983c7147 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lyricistant-bin
pkgdesc = A helpful writing assistant for lyricists!
pkgver = 3.3.0
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/wardellbagby/lyricistant
arch = aarch64
arch = x86_64
@@ -12,7 +12,7 @@ pkgbase = lyricistant-bin
provides = lyricistant=3.3.0
conflicts = lyricistant
source = lyricistant.sh
- sha256sums = c6acde5c6292a33c72ee35a0871aa91499363ebb586d2d95e9c83fde823b533f
+ sha256sums = b0388bd85d16d06a8b031662eb6e073489b7de9d9c31dff14d8f3d6084fe5c06
source_aarch64 = lyricistant-3.3.0-aarch64.AppImage::https://github.com/wardellbagby/lyricistant/releases/download/v3.3.0/lyricistant-linux_arm64.AppImage
sha256sums_aarch64 = 42b1f2479db56cf61355840a5ccd7cdac43d87e4d67be386b20e911f1df4aa3e
source_x86_64 = lyricistant-3.3.0-x86_64.AppImage::https://github.com/wardellbagby/lyricistant/releases/download/v3.3.0/lyricistant-linux_x86_64.AppImage
diff --git a/PKGBUILD b/PKGBUILD
index d282e0b23b6b..cca5d47949ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=lyricistant-bin
pkgver=3.3.0
-pkgrel=3
+pkgrel=4
pkgdesc="A helpful writing assistant for lyricists!"
arch=('aarch64' 'x86_64')
url="https://github.com/wardellbagby/lyricistant"
@@ -12,17 +12,17 @@ conflicts=("${pkgname%-bin}")
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.AppImage::${url}/releases/download/v${pkgver}/${pkgname%-bin}-linux_arm64.AppImage")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.AppImage::${url}/releases/download/v${pkgver}/${pkgname%-bin}-linux_x86_64.AppImage")
source=("${pkgname%-bin}.sh")
-sha256sums=('c6acde5c6292a33c72ee35a0871aa91499363ebb586d2d95e9c83fde823b533f')
+sha256sums=('b0388bd85d16d06a8b031662eb6e073489b7de9d9c31dff14d8f3d6084fe5c06')
sha256sums_aarch64=('42b1f2479db56cf61355840a5ccd7cdac43d87e4d67be386b20e911f1df4aa3e')
sha256sums_x86_64=('8cd2acea45922ce45dbc9809b746ddefd6d5f3eab80471968f949bf2dd26be4a')
prepare() {
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}-${CARCH}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}-${CARCH}.AppImage" --appimage-extract > /dev/null
+ sed "s|AppRun --no-sandbox %U|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
}
package() {
- install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
- install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.asar"
- sed "s|AppRun --no-sandbox %U|/opt/${pkgname%-bin}/${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" -t "${pkgdir}/opt/${pkgname%-bin}/resources"
install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
for _icons in 16x16 32x32 48x48 64x64 128x128 256x256 512x512;do
install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
diff --git a/lyricistant.sh b/lyricistant.sh
index 322f6cdb43ef..a080c97202eb 100644
--- a/lyricistant.sh
+++ b/lyricistant.sh
@@ -1,6 +1,6 @@
#!/bin/bash
_ELECTRON=/usr/bin/electron25
-_ASAR="/opt/lyricistant/lyricistant.asar"
+_ASAR="/opt/lyricistant/resources/app.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
exec ${_ELECTRON} ${_ASAR} "$@"
else