summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-16 17:31:39 +0800
committerzxp198210052024-01-16 17:31:39 +0800
commit4f1fbdf11b7340599b7299335001228fb6bf98f7 (patch)
tree5fa458f826d7bf3cc0ea1266590f391eb336132a
parent0cc876ddf080c739d1ce1b787f089d58cf4f35e6 (diff)
downloadaur-4f1fbdf11b7340599b7299335001228fb6bf98f7.tar.gz
fix errors
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
-rw-r--r--lyricistant.sh13
3 files changed, 14 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f162dc11f189..b03875cde937 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,20 @@
pkgbase = lyricistant-bin
pkgdesc = A helpful writing assistant for lyricists!
pkgver = 3.3.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/wardellbagby/lyricistant
arch = aarch64
arch = x86_64
license = GPL3
depends = electron27
depends = hicolor-icon-theme
- depends = libx11
- depends = gdk-pixbuf2
- depends = libxext
depends = libdbusmenu-glib
depends = gtk2
depends = dbus-glib
provides = lyricistant=3.3.1
conflicts = lyricistant
source = lyricistant.sh
- sha256sums = 8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84
+ sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
source_aarch64 = lyricistant-3.3.1-aarch64.AppImage::https://github.com/wardellbagby/lyricistant/releases/download/v3.3.1%2Belectron.ios/lyricistant-linux_arm64.AppImage
sha256sums_aarch64 = 7c4defe5dd8f241ad09e2a62ef53d0e463ae050f0f22eeccc67d1316fc81dd54
source_x86_64 = lyricistant-3.3.1-x86_64.AppImage::https://github.com/wardellbagby/lyricistant/releases/download/v3.3.1%2Belectron.ios/lyricistant-linux_x86_64.AppImage
diff --git a/PKGBUILD b/PKGBUILD
index 49d2f22a7f5f..daef6ac4149b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=lyricistant-bin
pkgver=3.3.1
_electronversion=27
-pkgrel=2
+pkgrel=3
pkgdesc="A helpful writing assistant for lyricists!"
arch=(
'aarch64'
@@ -10,22 +10,19 @@ arch=(
)
url="https://github.com/wardellbagby/lyricistant"
license=('GPL3')
+provides=("${pkgname%-bin}=${pkgver}")
+conflicts=("${pkgname%-bin}")
depends=(
"electron${_electronversion}"
'hicolor-icon-theme'
- 'libx11'
- 'gdk-pixbuf2'
- 'libxext'
'libdbusmenu-glib'
'gtk2'
'dbus-glib'
)
-provides=("${pkgname%-bin}=${pkgver}")
-conflicts=("${pkgname%-bin}")
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.AppImage::${url}/releases/download/v${pkgver}%2Belectron.ios/${pkgname%-bin}-linux_arm64.AppImage")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.AppImage::${url}/releases/download/v${pkgver}%2Belectron.ios/${pkgname%-bin}-linux_x86_64.AppImage")
source=("${pkgname%-bin}.sh")
-sha256sums=('8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84')
+sha256sums=('d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
sha256sums_aarch64=('7c4defe5dd8f241ad09e2a62ef53d0e463ae050f0f22eeccc67d1316fc81dd54')
sha256sums_x86_64=('b1d03148affb5f54d381e69fadef8b1d55cb46d351dcdac39bad8ab1e6bed6c7')
build() {
@@ -35,7 +32,7 @@ build() {
-i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}-${CARCH}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}-${CARCH}.AppImage" --appimage-extract > /dev/null
- sed "s|AppRun --no-sandbox %U|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
+ sed "s|AppRun --no-sandbox|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
diff --git a/lyricistant.sh b/lyricistant.sh
index 2ec4412e5c4f..aacd8f895847 100644
--- a/lyricistant.sh
+++ b/lyricistant.sh
@@ -1,14 +1,15 @@
-#!/bin/bash
+#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
+_ASAR="${_APPDIR}/@appasar@"
export PATH="${_APPDIR}:${PATH}"
-export ELECTRON_IS_DEV=0
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
-_ASAR="${_APPDIR}/@appasar@"
+export ELECTRON_IS_DEV=0
+export NODE_ENV=production
+cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" "$@"
else
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi \ No newline at end of file
+fi
+exit \ No newline at end of file