summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-04-22 12:22:06 +0800
committerzxp198210052024-04-22 12:22:06 +0800
commit51e88f2dc122b019ceea102cb00efa8a534ac6f8 (patch)
treeeb4e2d76cad4d80440a8a549e42bae25a9a615cd
parentadab83a4b7db6d0bfac192c5ba1ef8f34637c8c4 (diff)
downloadaur-51e88f2dc122b019ceea102cb00efa8a534ac6f8.tar.gz
update to 3.4.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02aff7f710b1..9515d3a20bf2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = lyricistant-bin
pkgdesc = A helpful writing assistant for lyricists!
- pkgver = 3.3.4
+ pkgver = 3.4.0
pkgrel = 1
url = https://github.com/wardellbagby/lyricistant
arch = aarch64
@@ -8,13 +8,13 @@ pkgbase = lyricistant-bin
license = GPL-3.0-only
makedepends = fuse2
depends = electron30
- provides = lyricistant=3.3.4
+ provides = lyricistant=3.4.0
conflicts = lyricistant
source = lyricistant.sh
sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
- source_aarch64 = lyricistant-3.3.4-aarch64.AppImage::https://github.com/wardellbagby/lyricistant/releases/download/v3.3.4%2Bweb.electron/lyricistant-linux_arm64.AppImage
- sha256sums_aarch64 = 920cd755a8c31e5da3aadab7d43ea38550296d974041f055fec3dbc46d77ba34
- source_x86_64 = lyricistant-3.3.4-x86_64.AppImage::https://github.com/wardellbagby/lyricistant/releases/download/v3.3.4%2Bweb.electron/lyricistant-linux_x86_64.AppImage
- sha256sums_x86_64 = 25c87e71050c923417cf05f9c6b7e039c47391c85b6149e315adc2c68de9e1fa
+ source_aarch64 = lyricistant-3.4.0-aarch64.AppImage::https://github.com/wardellbagby/lyricistant/releases/download/v3.4.0/lyricistant-linux_arm64.AppImage
+ sha256sums_aarch64 = 7b6132f1a49685cc02ed030320f06d6f41402c16b375f252828c7afa64fab09e
+ source_x86_64 = lyricistant-3.4.0-x86_64.AppImage::https://github.com/wardellbagby/lyricistant/releases/download/v3.4.0/lyricistant-linux_x86_64.AppImage
+ sha256sums_x86_64 = c919348081b6bcfb2e1373a0974a627d1b38474555c268f338afeee057cf8053
pkgname = lyricistant-bin
diff --git a/PKGBUILD b/PKGBUILD
index 69a76b0da80f..7bd5d83c8dcb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,6 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=lyricistant-bin
-pkgver=3.3.4
-_subver=web.electron
+pkgver=3.4.0
_electronversion=30
pkgrel=1
pkgdesc="A helpful writing assistant for lyricists!"
@@ -19,12 +18,12 @@ depends=(
makedepends=(
'fuse2'
)
-source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.AppImage::${url}/releases/download/v${pkgver}%2B${_subver}/${pkgname%-bin}-linux_arm64.AppImage")
-source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.AppImage::${url}/releases/download/v${pkgver}%2B${_subver}/${pkgname%-bin}-linux_x86_64.AppImage")
+source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.AppImage::${url}/releases/download/v${pkgver}/${pkgname%-bin}-linux_arm64.AppImage")
+source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.AppImage::${url}/releases/download/v${pkgver}/${pkgname%-bin}-linux_x86_64.AppImage")
source=("${pkgname%-bin}.sh")
sha256sums=('dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
-sha256sums_aarch64=('920cd755a8c31e5da3aadab7d43ea38550296d974041f055fec3dbc46d77ba34')
-sha256sums_x86_64=('25c87e71050c923417cf05f9c6b7e039c47391c85b6149e315adc2c68de9e1fa')
+sha256sums_aarch64=('7b6132f1a49685cc02ed030320f06d6f41402c16b375f252828c7afa64fab09e')
+sha256sums_x86_64=('c919348081b6bcfb2e1373a0974a627d1b38474555c268f338afeee057cf8053')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \