summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-26 17:02:02 +0800
committerzxp198210052024-02-26 17:02:02 +0800
commit84a764cec9fa648ea5adb6ef29f6f29f34395104 (patch)
tree58e26a6021e0abc94c041393c213b6e605f46daf
parent4f1fbdf11b7340599b7299335001228fb6bf98f7 (diff)
downloadaur-84a764cec9fa648ea5adb6ef29f6f29f34395104.tar.gz
fix errors
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
-rw-r--r--lyricistant.sh9
3 files changed, 11 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b03875cde937..1ee57b09126c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,17 @@
pkgbase = lyricistant-bin
pkgdesc = A helpful writing assistant for lyricists!
pkgver = 3.3.1
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/wardellbagby/lyricistant
arch = aarch64
arch = x86_64
- license = GPL3
+ license = GPL-3.0-only
depends = electron27
depends = hicolor-icon-theme
- depends = libdbusmenu-glib
- depends = gtk2
- depends = dbus-glib
provides = lyricistant=3.3.1
conflicts = lyricistant
source = lyricistant.sh
- sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
+ sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
source_aarch64 = lyricistant-3.3.1-aarch64.AppImage::https://github.com/wardellbagby/lyricistant/releases/download/v3.3.1%2Belectron.ios/lyricistant-linux_arm64.AppImage
sha256sums_aarch64 = 7c4defe5dd8f241ad09e2a62ef53d0e463ae050f0f22eeccc67d1316fc81dd54
source_x86_64 = lyricistant-3.3.1-x86_64.AppImage::https://github.com/wardellbagby/lyricistant/releases/download/v3.3.1%2Belectron.ios/lyricistant-linux_x86_64.AppImage
diff --git a/PKGBUILD b/PKGBUILD
index daef6ac4149b..7f57a6b84567 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,30 @@
pkgname=lyricistant-bin
pkgver=3.3.1
_electronversion=27
-pkgrel=3
+pkgrel=4
pkgdesc="A helpful writing assistant for lyricists!"
arch=(
'aarch64'
'x86_64'
)
url="https://github.com/wardellbagby/lyricistant"
-license=('GPL3')
+license=('GPL-3.0-only')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
"electron${_electronversion}"
'hicolor-icon-theme'
- 'libdbusmenu-glib'
- 'gtk2'
- 'dbus-glib'
)
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.AppImage::${url}/releases/download/v${pkgver}%2Belectron.ios/${pkgname%-bin}-linux_arm64.AppImage")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.AppImage::${url}/releases/download/v${pkgver}%2Belectron.ios/${pkgname%-bin}-linux_x86_64.AppImage")
source=("${pkgname%-bin}.sh")
-sha256sums=('d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
+sha256sums=('0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
sha256sums_aarch64=('7c4defe5dd8f241ad09e2a62ef53d0e463ae050f0f22eeccc67d1316fc81dd54')
sha256sums_x86_64=('b1d03148affb5f54d381e69fadef8b1d55cb46d351dcdac39bad8ab1e6bed6c7')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@appasar@|app.asar|g" \
+ -e "s|@runname@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}-${CARCH}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}-${CARCH}.AppImage" --appimage-extract > /dev/null
@@ -37,7 +34,6 @@ build() {
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
install -Dm644 "${srcdir}/squashfs-root/resources/app.asar" -t "${pkgdir}/usr/lib/${pkgname%-bin}"
- install -Dm644 "${srcdir}/squashfs-root/usr/lib/"* -t "${pkgdir}/usr/lib/${pkgname%-bin}/lib"
install -Dm644 "${srcdir}/squashfs-root/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
for _icons in 16x16 32x32 48x48 64x64 128x128 256x256 512x512;do
install -Dm644 "${srcdir}/squashfs-root/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
diff --git a/lyricistant.sh b/lyricistant.sh
index aacd8f895847..f9ced1432cfc 100644
--- a/lyricistant.sh
+++ b/lyricistant.sh
@@ -1,15 +1,14 @@
#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
-_ASAR="${_APPDIR}/@appasar@"
+_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_ASAR}" "$@"
+ exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
else
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi
-exit \ No newline at end of file
+ exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+fi \ No newline at end of file