summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-04-22 10:53:11 +0800
committerzxp198210052024-04-22 10:53:11 +0800
commitadab83a4b7db6d0bfac192c5ba1ef8f34637c8c4 (patch)
tree8d0b79c04055dd79ecaa7f435cb98941751d7ace
parent1a03580e0073792a4c9d8708a49329ef2465a1c8 (diff)
downloadaur-adab83a4b7db6d0bfac192c5ba1ef8f34637c8c4.tar.gz
update to 3.3.4
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD18
2 files changed, 17 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0855f4fb515d..02aff7f710b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,20 @@
pkgbase = lyricistant-bin
pkgdesc = A helpful writing assistant for lyricists!
- pkgver = 3.3.1
- pkgrel = 5
+ pkgver = 3.3.4
+ pkgrel = 1
url = https://github.com/wardellbagby/lyricistant
arch = aarch64
arch = x86_64
license = GPL-3.0-only
makedepends = fuse2
- depends = electron27
- depends = hicolor-icon-theme
- provides = lyricistant=3.3.1
+ depends = electron30
+ provides = lyricistant=3.3.4
conflicts = lyricistant
source = lyricistant.sh
sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
- source_aarch64 = lyricistant-3.3.1-aarch64.AppImage::https://github.com/wardellbagby/lyricistant/releases/download/v3.3.1%2Belectron.ios/lyricistant-linux_arm64.AppImage
- sha256sums_aarch64 = 7c4defe5dd8f241ad09e2a62ef53d0e463ae050f0f22eeccc67d1316fc81dd54
- source_x86_64 = lyricistant-3.3.1-x86_64.AppImage::https://github.com/wardellbagby/lyricistant/releases/download/v3.3.1%2Belectron.ios/lyricistant-linux_x86_64.AppImage
- sha256sums_x86_64 = b1d03148affb5f54d381e69fadef8b1d55cb46d351dcdac39bad8ab1e6bed6c7
+ source_aarch64 = lyricistant-3.3.4-aarch64.AppImage::https://github.com/wardellbagby/lyricistant/releases/download/v3.3.4%2Bweb.electron/lyricistant-linux_arm64.AppImage
+ sha256sums_aarch64 = 920cd755a8c31e5da3aadab7d43ea38550296d974041f055fec3dbc46d77ba34
+ source_x86_64 = lyricistant-3.3.4-x86_64.AppImage::https://github.com/wardellbagby/lyricistant/releases/download/v3.3.4%2Bweb.electron/lyricistant-linux_x86_64.AppImage
+ sha256sums_x86_64 = 25c87e71050c923417cf05f9c6b7e039c47391c85b6149e315adc2c68de9e1fa
pkgname = lyricistant-bin
diff --git a/PKGBUILD b/PKGBUILD
index b3b0e1b3a04f..69a76b0da80f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=lyricistant-bin
-pkgver=3.3.1
-_electronversion=27
-pkgrel=5
+pkgver=3.3.4
+_subver=web.electron
+_electronversion=30
+pkgrel=1
pkgdesc="A helpful writing assistant for lyricists!"
arch=(
'aarch64'
@@ -14,22 +15,21 @@ provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
depends=(
"electron${_electronversion}"
- 'hicolor-icon-theme'
)
makedepends=(
'fuse2'
)
-source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.AppImage::${url}/releases/download/v${pkgver}%2Belectron.ios/${pkgname%-bin}-linux_arm64.AppImage")
-source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.AppImage::${url}/releases/download/v${pkgver}%2Belectron.ios/${pkgname%-bin}-linux_x86_64.AppImage")
+source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.AppImage::${url}/releases/download/v${pkgver}%2B${_subver}/${pkgname%-bin}-linux_arm64.AppImage")
+source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.AppImage::${url}/releases/download/v${pkgver}%2B${_subver}/${pkgname%-bin}-linux_x86_64.AppImage")
source=("${pkgname%-bin}.sh")
sha256sums=('dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
-sha256sums_aarch64=('7c4defe5dd8f241ad09e2a62ef53d0e463ae050f0f22eeccc67d1316fc81dd54')
-sha256sums_x86_64=('b1d03148affb5f54d381e69fadef8b1d55cb46d351dcdac39bad8ab1e6bed6c7')
+sha256sums_aarch64=('920cd755a8c31e5da3aadab7d43ea38550296d974041f055fec3dbc46d77ba34')
+sha256sums_x86_64=('25c87e71050c923417cf05f9c6b7e039c47391c85b6149e315adc2c68de9e1fa')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
- -e "s|@options@||g" \
+ -e "s|@options@|env ELECTRON_OZONE_PLATFORM_HINT=auto|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}-${CARCH}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}-${CARCH}.AppImage" --appimage-extract > /dev/null