summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-08-07 12:06:34 +0800
committerzxp198210052023-08-07 12:06:34 +0800
commiteab33b03d00751f14309024110d6c9fc65907691 (patch)
treec953ee46f881bdb3d0bbb3d7b96e5bfcbe81a524
parent01fe8f9ca94d0707a8f782d8513665545766864c (diff)
downloadaur-eab33b03d00751f14309024110d6c9fc65907691.tar.gz
fix errors
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD7
-rw-r--r--lyricistant.sh6
3 files changed, 13 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7b1231b988f..9900afd1a64a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = lyricistant-bin
pkgdesc = A helpful writing assistant for lyricists!
pkgver = 3.3.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/wardellbagby/lyricistant
arch = aarch64
arch = x86_64
license = GPL3
- depends = electron
+ depends = bash
+ depends = electron25
depends = hicolor-icon-theme
+ provides = lyricistant
conflicts = lyricistant
source = lyricistant.sh
- sha256sums = 4ab50fa1f95feb88249477630af8c2db71bb2c1973a2b5ffd8cb1f7d27db065a
+ sha256sums = c6acde5c6292a33c72ee35a0871aa91499363ebb586d2d95e9c83fde823b533f
source_aarch64 = lyricistant-3.3.0-aarch64.AppImage::https://github.com/wardellbagby/lyricistant/releases/download/v3.3.0/lyricistant-linux_arm64.AppImage
sha256sums_aarch64 = 42b1f2479db56cf61355840a5ccd7cdac43d87e4d67be386b20e911f1df4aa3e
source_x86_64 = lyricistant-3.3.0-x86_64.AppImage::https://github.com/wardellbagby/lyricistant/releases/download/v3.3.0/lyricistant-linux_x86_64.AppImage
diff --git a/PKGBUILD b/PKGBUILD
index 89aa4a205f3f..d7e80d189c1d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=lyricistant-bin
pkgver=3.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="A helpful writing assistant for lyricists!"
arch=('aarch64' 'x86_64')
url="https://github.com/wardellbagby/lyricistant"
license=('GPL3')
-depends=('electron' 'hicolor-icon-theme')
+depends=('bash' 'electron25' 'hicolor-icon-theme')
+provides=("${pkgname%-bin}")
conflicts=("${pkgname%-bin}")
_install_path="/opt/appimages"
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.AppImage::${url}/releases/download/v${pkgver}/${pkgname%-bin}-linux_arm64.AppImage")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.AppImage::${url}/releases/download/v${pkgver}/${pkgname%-bin}-linux_x86_64.AppImage")
source=("${pkgname%-bin}.sh")
-sha256sums=('4ab50fa1f95feb88249477630af8c2db71bb2c1973a2b5ffd8cb1f7d27db065a')
+sha256sums=('c6acde5c6292a33c72ee35a0871aa91499363ebb586d2d95e9c83fde823b533f')
sha256sums_aarch64=('42b1f2479db56cf61355840a5ccd7cdac43d87e4d67be386b20e911f1df4aa3e')
sha256sums_x86_64=('8cd2acea45922ce45dbc9809b746ddefd6d5f3eab80471968f949bf2dd26be4a')
prepare() {
diff --git a/lyricistant.sh b/lyricistant.sh
index 0ffd5161b6cc..322f6cdb43ef 100644
--- a/lyricistant.sh
+++ b/lyricistant.sh
@@ -1,6 +1,8 @@
#!/bin/bash
+_ELECTRON=/usr/bin/electron25
+_ASAR="/opt/lyricistant/lyricistant.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron /opt/lyricistant/lyricistant.asar "$@"
+ exec ${_ELECTRON} ${_ASAR} "$@"
else
- exec electron --no-sandbox /opt/lyricistant/lyricistant.asar "$@"
+ exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@"
fi \ No newline at end of file