summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBalló György2020-07-23 13:18:06 +0000
committerBalló György2020-07-23 13:18:06 +0000
commitb6ac9807bdb862d59e676ef9efa16d8c77f90128 (patch)
treed218bf98388902650dcb23d87aad05ddbc19ba0b
downloadaur-b6ac9807bdb862d59e676ef9efa16d8c77f90128.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2c30f432f00a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = lyricsources
+ pkgdesc = Lyric downloader dbus service from osdlyrics
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/naaando/lyricsources
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ depends = python2-dbus
+ depends = python2-gobject
+ depends = python2-pycurl
+ source = https://github.com/naaando/lyricsources/archive/0.1/lyricsources-0.1.tar.gz
+ sha256sums = 363407184541762121a954d1d96265d86510906a38662f4f5113e5c5bc4405e7
+
+pkgname = lyricsources
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8bc411835dea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
+
+pkgname=lyricsources
+pkgver=0.1
+pkgrel=1
+pkgdesc="Lyric downloader dbus service from osdlyrics"
+arch=(any)
+url="https://github.com/naaando/lyricsources"
+license=(GPL3)
+depends=(python2-dbus python2-gobject python2-pycurl)
+makedepends=(git meson)
+source=(https://github.com/naaando/$pkgname/archive/$pkgver/$pkgname-$pkgver.tar.gz)
+sha256sums=('363407184541762121a954d1d96265d86510906a38662f4f5113e5c5bc4405e7')
+
+build() {
+ arch-meson $pkgname-$pkgver build
+ meson compile -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}