summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-05-12 12:41:53 -0500
committerCarlos Aznarán Laos2022-05-12 12:41:53 -0500
commit7fbd3c6311ea15b37346cd5d5a64fd071e3221fa (patch)
treef8d0026f6011ad7d313f006166a7bea6f0e8b518
parent18466c0b7f9c0b5f2df7269865533bffecb785d5 (diff)
downloadaur-7fbd3c6311ea15b37346cd5d5a64fd071e3221fa.tar.gz
Fix including C++ headers for work with latest compiler
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD17
2 files changed, 15 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0214835f221c..48f2caeef881 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lyx
pkgdesc = An advanced WYSIWYM document processor & LaTeX front-end
pkgver = 2.3.6.1
- pkgrel = 5
+ pkgrel = 6
url = https://www.lyx.org
arch = x86_64
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index 8776f7e9927b..ee4f180e15bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=lyx
pkgver=2.3.6.1
-pkgrel=5
+pkgrel=6
pkgdesc="An advanced WYSIWYM document processor & LaTeX front-end"
arch=('x86_64')
url="https://www.lyx.org"
@@ -25,10 +25,21 @@ sha512sums=('b2f24d32c3716144fc19a5187d59dce86c718e9180b3b33826a04477c5deeed8238
'SKIP'
'eef777cf6033a7b1e04700f33068b07309f8d5c6931c16927305dafb3a00fd46d4b536149349ab56b7455e7dea195c8889da2b6fbf9caa9e76bc0557f9358bc3')
+prepare() {
+ # Expand the automake compatibility version
+ sed -i 's/2.6\[5-9\]/2.7\[1-9\]/' "${pkgname}-${pkgver}"/autogen.sh
+ # Add missing headers for work with GCC 12.1.0 or later
+ sed -i '54 a #include <iterator>' "${pkgname}-${pkgver}"/src/lyxfind.cpp
+ sed -i '45 a #include <cstring>' "${pkgname}-${pkgver}"/src/insets/InsetListings.cpp
+}
+
build() {
cd "${pkgname}-${pkgver}"
- ./configure --prefix=/usr \
- --enable-qt5 --without-included-boost \
+ ./autogen.sh
+ ./configure \
+ --prefix=/usr \
+ --enable-qt5 \
+ --without-included-boost \
--without-included-mythes
make
}