summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2017-07-31 11:16:08 -0400
committerGuillaume Horel2017-07-31 11:16:08 -0400
commit374c9f692b11a970534cbfb335b3fe6aea896f88 (patch)
tree71fd4f1e8553e7c67133a7973757cd781996f720
downloadaur-374c9f692b11a970534cbfb335b3fe6aea896f88.tar.gz
initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD42
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..592c8bcab0a2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = lz4-static
+ pkgdesc = Extremely fast compression algorithm (static version)
+ pkgver = 1.7.5
+ pkgrel = 1
+ epoch = 1
+ url = http://www.lz4.org/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ checkdepends = diffutils
+ makedepends = git
+ depends = glibc
+ provides = lz4
+ conflicts = lz4
+ options = staticlibs
+ source = git+https://github.com/lz4/lz4.git#tag=v1.7.5
+ md5sums = SKIP
+
+pkgname = lz4-static
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f3f44c0d85f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+
+pkgname=lz4-static
+_pkgname="${pkgname%-static}"
+epoch=1
+pkgver=1.7.5
+pkgrel=1
+pkgdesc='Extremely fast compression algorithm (static version)'
+arch=('i686' 'x86_64')
+url='http://www.lz4.org/'
+license=('GPL2')
+makedepends=('git')
+checkdepends=('diffutils')
+depends=('glibc')
+source=("git+https://github.com/lz4/lz4.git#tag=v$pkgver")
+md5sums=('SKIP')
+options=('staticlibs')
+provides=('lz4')
+conflicts=('lz4')
+
+build() {
+ # do not use the main makefile, it calls sub make with -e
+ # exported CLFAGS by makepkg break the version. see FS#50071
+ cd $_pkgname
+ make -C lib PREFIX=/usr CFLAGS="$CFLAGS -fPIC"
+ make -C programs PREFIX=/usr lz4 lz4c
+}
+
+check() {
+ rm -f passwd.lz4
+ $_pkgname/programs/lz4 /etc/passwd passwd.lz4
+ $_pkgname/programs/lz4 -d passwd.lz4 passwd
+ diff -q /etc/passwd passwd
+ rm passwd
+}
+
+package() {
+ cd $_pkgname
+ make install PREFIX=/usr DESTDIR="$pkgdir"
+}
+
+# vim:set ts=2 sw=2 et: