summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRanieri Althoff2019-05-13 14:12:23 -0300
committerRanieri Althoff2019-05-13 14:15:44 -0300
commite7bbd5f7af89e28ea994172eb54a4c9e74cfafdc (patch)
treee00062caf750d47a14ec27535635103dbe014e7b
downloadaur-e7bbd5f7af89e28ea994172eb54a4c9e74cfafdc.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD44
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fb25926c871a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = lz4-static-musl
+ pkgdesc = Extremely fast compression algorithm
+ pkgver = 1.9.1
+ pkgrel = 1
+ epoch = 1
+ url = http://www.lz4.org/
+ arch = x86_64
+ license = GPL2
+ checkdepends = diffutils
+ makedepends = git
+ makedepends = musl
+ provides = lz4=1.9.1
+ conflicts = lz4
+ source = git+https://github.com/lz4/lz4.git#tag=v1.9.1
+ md5sums = SKIP
+
+pkgname = lz4-static-musl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b5df6ba3924e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Ranieri Althoff <ranisalt+aur at gmail dot com>
+# Contributor: Sébastien Luttringer
+
+_pkgname=lz4
+pkgname=${_pkgname}-static-musl
+epoch=1
+pkgver=1.9.1
+pkgrel=1
+pkgdesc='Extremely fast compression algorithm'
+arch=('x86_64')
+url='http://www.lz4.org/'
+license=('GPL2')
+makedepends=('git' 'musl')
+checkdepends=('diffutils')
+provides=("${_pkgname}=${pkgver}")
+conflicts=('lz4')
+source=("git+https://github.com/lz4/lz4.git#tag=v$pkgver")
+md5sums=('SKIP')
+
+build() {
+ export CC="musl-gcc"
+ export CFLAGS="$CFLAGS -fPIC -static"
+
+ # do not use the main makefile, it calls sub make with -e
+ # exported CLFAGS by makepkg break the version. see FS#50071
+ cd $_pkgname
+ make -C lib PREFIX=/usr
+ make -C programs PREFIX=/usr lz4 lz4c
+}
+
+check() {
+ rm -f passwd.lz4
+ $_pkgname/programs/lz4 /etc/passwd passwd.lz4
+ $_pkgname/programs/lz4 -d passwd.lz4 passwd
+ diff -q /etc/passwd passwd
+ rm passwd
+}
+
+package() {
+ cd $_pkgname
+ make install PREFIX=/usr DESTDIR="$pkgdir"
+}
+
+# vim:set ts=2 sw=2 et: