summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfatalis2017-12-22 18:17:45 -0600
committerfatalis2017-12-22 18:22:11 -0600
commitcf98d20fae1ab179c1a968a59b45e5ecb3876910 (patch)
treec88ff57a3258df5983daae2c12d7157381cfd1dd
downloadaur-cf98d20fae1ab179c1a968a59b45e5ecb3876910.tar.gz
1.7.1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
-rw-r--r--no-static.patch13
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ec2777330ab9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = lzbench
+ pkgdesc = An in-memory benchmark of open-source LZ77/LZSS/LZMA compressors
+ pkgver = 1.7.1
+ pkgrel = 1
+ url = https://github.com/inikep/lzbench
+ arch = x86_64
+ license = unknown
+ depends = gcc-libs
+ conflicts = lzbench-git
+ source = https://github.com/inikep/lzbench/archive/v1.7.1.tar.gz
+ source = no-static.patch
+ sha256sums = 751a7544a54fae050f5d7fd64c470da9cbc31cd126b43366ff495a2923cd7471
+ sha256sums = 0e3f1de18f9da318163a7c771a4c15fee38b16c2f26390ee61b51eef0d9eb19e
+
+pkgname = lzbench
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..940f7549064e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: fatalis <fatalis@fatalis.pw>
+pkgname=lzbench
+pkgver=1.7.1
+pkgrel=1
+pkgdesc='An in-memory benchmark of open-source LZ77/LZSS/LZMA compressors'
+arch=('x86_64')
+url='https://github.com/inikep/lzbench'
+license=('unknown')
+depends=('gcc-libs')
+conflicts=('lzbench-git')
+source=("${url}/archive/v${pkgver}.tar.gz"
+ 'no-static.patch')
+sha256sums=('751a7544a54fae050f5d7fd64c470da9cbc31cd126b43366ff495a2923cd7471'
+ '0e3f1de18f9da318163a7c771a4c15fee38b16c2f26390ee61b51eef0d9eb19e')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ patch -p0 < ../no-static.patch
+}
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ install -Dm755 lzbench "${pkgdir}/usr/bin/lzbench"
+}
diff --git a/no-static.patch b/no-static.patch
new file mode 100644
index 000000000000..878fea9b1e97
--- /dev/null
+++ b/no-static.patch
@@ -0,0 +1,13 @@
+diff --git Makefile Makefile
+index 11d1259..01c4cd7 100644
+--- Makefile
++++ Makefile
+@@ -51,7 +51,7 @@ else
+ DONT_BUILD_LZHAM ?= 1
+ DONT_BUILD_CSC ?= 1
+ else
+- LDFLAGS += -lrt -static
++ LDFLAGS += -lrt
+ endif
+ LDFLAGS += -lpthread
+ endif