summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2019-11-02 13:59:46 +0200
committerDimitris Kiziridis2019-11-02 13:59:46 +0200
commit02f8ab1152e2640001d0214e82b498ecdef12715 (patch)
tree0e4ba9c7caa44d891494b6f97062b61fd8ac0329
downloadaur-02f8ab1152e2640001d0214e82b498ecdef12715.tar.gz
Initial commit.
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD35
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e26910b2af88
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = lzdoom-bin
+ pkgdesc = Fork of GZDoom 3.3.2 for legacy systems..
+ pkgver = 3.83a
+ pkgrel = 1
+ arch = i686
+ arch = x86_64
+ groups =
+ license = GPL
+ depends = sdl2
+ depends = zlib
+ optdepends = fluidsynth
+ optdepends = libsndfile
+ optdepends = mpg123
+ optdepends = openal
+ optdepends = timidity++
+ options = !strip
+ options = !emptydirs
+ source_i686 = https://github.com/drfrag666/gzdoom/releases/download/3.83a/lzdoom_3.83a_i386.deb
+ sha512sums_i686 = c591d1720a76c6d4c85d394808bbe354a5f9241c88914bcd8f6bc25c3fc5538389ec3c59bf33b343b22673a1474652d043ffd09b18c511e3a8f938fd36fc8a8e
+ source_x86_64 = https://github.com/drfrag666/gzdoom/releases/download/3.83a/lzdoom_3.83a_amd64.deb
+ sha512sums_x86_64 = e5bccefd2eb9a8b28aa1d62e24e91f52ee5cfa3b6c529ff21acacec01ec33d9f612709f563696bb5320c93f251ea5e8a14b1b0a05b23e022972faa33fc98a678
+
+pkgname = lzdoom-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db62dac7bf41
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Dimitris Kiziridis <ragouel@outlook.com>
+
+pkgname=lzdoom-bin
+pkgver=3.83a
+pkgrel=1
+pkgdesc="Fork of GZDoom 3.3.2 for legacy systems.."
+arch=('i686' 'x86_64')
+url=""
+license=('GPL')
+groups=('')
+depends=('sdl2' 'zlib')
+optdepends=('fluidsynth'
+ 'libsndfile'
+ 'mpg123'
+ 'openal'
+ 'timidity++')
+options=('!strip' '!emptydirs')
+source_i686=("https://github.com/drfrag666/gzdoom/releases/download/3.83a/lzdoom_3.83a_i386.deb")
+source_x86_64=("https://github.com/drfrag666/gzdoom/releases/download/3.83a/lzdoom_3.83a_amd64.deb")
+sha512sums_i686=('c591d1720a76c6d4c85d394808bbe354a5f9241c88914bcd8f6bc25c3fc5538389ec3c59bf33b343b22673a1474652d043ffd09b18c511e3a8f938fd36fc8a8e')
+sha512sums_x86_64=('e5bccefd2eb9a8b28aa1d62e24e91f52ee5cfa3b6c529ff21acacec01ec33d9f612709f563696bb5320c93f251ea5e8a14b1b0a05b23e022972faa33fc98a678')
+
+package(){
+
+ # Extract package data
+ tar xf data.tar.xz -C "${pkgdir}"
+
+ # Fix directories structure differencies
+ cd "${pkgdir}"
+
+ mkdir usr/bin 2> /dev/null; mv usr/games/* usr/bin; rm -rf usr/games
+
+ cd ..
+
+}