summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-28 20:17:14 +0100
committerJaroslav Lichtblau2014-11-28 20:17:14 +0100
commit9ea21f75716271259788dadd155954b2bdc479a5 (patch)
tree7f985a58b0a859c439d07d6aa8c3b992eb307d7a
downloadaur-9ea21f75716271259788dadd155954b2bdc479a5.tar.gz
Initial PKGBUILD status as of 28.11.2014
-rw-r--r--.AURINFO16
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
-rw-r--r--lzlib.install22
4 files changed, 84 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..8b71ac08207f
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,16 @@
+pkgbase = lzlib
+ pkgdesc = A library providing in-memory LZMA compression and decompression functions
+ pkgver = 1.6
+ pkgrel = 1
+ url = http://www.nongnu.org/lzip/lzlib.html
+ install = lzlib.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = gcc-libs
+ options = !emptydirs
+ source = http://download.savannah.gnu.org/releases/lzip/lzlib/lzlib-1.6.tar.gz
+ sha256sums = c187ef5ffa9ffb01abaec667dda4d8c8b378291c68ad094c63bd75ee049e4780
+
+pkgname = lzlib
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8b71ac08207f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = lzlib
+ pkgdesc = A library providing in-memory LZMA compression and decompression functions
+ pkgver = 1.6
+ pkgrel = 1
+ url = http://www.nongnu.org/lzip/lzlib.html
+ install = lzlib.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = gcc-libs
+ options = !emptydirs
+ source = http://download.savannah.gnu.org/releases/lzip/lzlib/lzlib-1.6.tar.gz
+ sha256sums = c187ef5ffa9ffb01abaec667dda4d8c8b378291c68ad094c63bd75ee049e4780
+
+pkgname = lzlib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3108cdc07193
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+# Contributor: Christoph Zeiler <archNOSPAM_at_moonblade.dot.org>
+
+pkgname=lzlib
+pkgver=1.6
+pkgrel=1
+pkgdesc="A library providing in-memory LZMA compression and decompression functions"
+arch=('i686' 'x86_64')
+url="http://www.nongnu.org/lzip/lzlib.html"
+license=('GPL3')
+depends=('gcc-libs')
+options=('!emptydirs')
+install=$pkgname.install
+source=(http://download.savannah.gnu.org/releases/lzip/lzlib/$pkgname-$pkgver.tar.gz)
+sha256sums=('c187ef5ffa9ffb01abaec667dda4d8c8b378291c68ad094c63bd75ee049e4780')
+
+build() {
+ cd "${srcdir}"/$pkgname-$pkgver
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}"/$pkgname-$pkgver
+
+ make DESTDIR="${pkgdir}" install
+
+ install -Dm755 minilzip "${pkgdir}"/usr/bin/minilzip
+}
diff --git a/lzlib.install b/lzlib.install
new file mode 100644
index 000000000000..6e6da76c41f0
--- /dev/null
+++ b/lzlib.install
@@ -0,0 +1,22 @@
+infodir=/usr/share/info
+filelist=(lzlib.info)
+
+post_install() {
+ [ -x usr/bin/install-info ] || return 0
+ for file in ${filelist[@]}; do
+ install-info $infodir/$file $infodir/dir 2> /dev/null
+ done
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ [ -x usr/bin/install-info ] || return 0
+ for file in ${filelist[@]}; do
+ install-info --delete $infodir/$file $infodir/dir 2> /dev/null
+ done
+}
+
+# vim:set ts=2 sw=2 et: