aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvvasuki2020-03-01 19:53:03 +0530
committervvasuki2020-03-01 19:53:03 +0530
commit53c5dbd211659fc0e108265628b96170417aabb3 (patch)
tree7af9d4f7262ceb82d88d69ab4cd5d617cf8742e9
downloadaur-53c5dbd211659fc0e108265628b96170417aabb3.tar.gz
CU
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore10
-rw-r--r--PKGBUILD36
-rw-r--r--README.md14
4 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b224fe0f93bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = m17n-db-indic
+ pkgdesc = A library to type in a variety of scripts. This is a fork of m17n-db modified with files from m17n-db-indic-aur (see url) for convenience of Indian (esp. sanskrit, kannada) users.
+ pkgver = 1.8.0
+ pkgrel = 2
+ url = http://github.com/sanskrit-coders/m17n-db-indic-aur
+ arch = any
+ license = GPL
+ depends = glibc
+ provides = m17n-db
+ conflicts = m17n-db
+ source = https://download.savannah.gnu.org/releases/m17n/m17n-db-1.8.0.tar.gz
+ sha256sums = 657f23835b6655e7a63a362bac66260454ee356da4855eadb9366911d33fdc6d
+
+pkgname = m17n-db-indic
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..65c36083f8a6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,10 @@
+*.iml
+
+# Arch linux packaging.
+releases
+pkg
+src
+aur
+*.tar.gz
+*.tar.xz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e1a171579da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+#Maintainer: Sanskrit Coders <sanskrit-programmers@googlegroups.com>
+# Much of the file is copied from https://git.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/m17n-db
+pkgname=m17n-db-indic
+pkgname_basic=m17n-db
+pkgver=1.8.0
+pkgrel=2
+pkgdesc='A library to type in a variety of scripts. This is a fork of m17n-db modified with files from m17n-db-indic-aur (see url) for convenience of Indian (esp. sanskrit, kannada) users.'
+license=('GPL')
+provides=("${pkgname_basic}")
+conflicts=("${pkgname_basic}")
+depends=('glibc') # not because of compiling, but because of /usr/share/i18n/charmaps/ files that glibc provides
+source=("https://download.savannah.gnu.org/releases/m17n/${pkgname_basic}-${pkgver}.tar.gz")
+sha256sums=('657f23835b6655e7a63a362bac66260454ee356da4855eadb9366911d33fdc6d')
+url="http://github.com/sanskrit-coders/m17n-db-indic-aur"
+# license=('custom:OFL')
+arch=(any)
+
+build() {
+ rm -rf "$srcdir/m17n-db-indic/"
+ git clone https://github.com/sanskrit-coders/m17n-db-indic.git
+
+ cd ${pkgname_basic}-${pkgver}
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${pkgname_basic}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+ # Drop script that makes UIM segfault http://savannah.nongnu.org/bugs/index.php?53202
+ rm "$pkgdir"/usr/share/m17n/hu-rovas-post.mim
+
+ cd "$srcdir/m17n-db-indic/"
+ cp -f "$srcdir/m17n-db-indic/"*.mim "$pkgdir/usr/share/m17n/"
+ cp -rf "$srcdir/m17n-db-indic/icons" "$pkgdir/usr/share/m17n/"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..0565c016c8eb
--- /dev/null
+++ b/README.md
@@ -0,0 +1,14 @@
+
+- AUR package location: <https://aur.archlinux.org/packages/m17n-db-indic/>
+- Package source code locations:
+ - git clone git@github.com:sanskrit-coders/m17n-db-indic-aur.git
+ - git clone ssh://aur@aur.archlinux.org/m17n-db-indic.git
+
+# Creating a new Arch Linux package release
+- Update PKGBUILD.
+ - Fix the version numbers.
+- Verify package by running `makepkg -si`.
+- Update AUR repository.
+ - Set remote: `git remote add origin ssh://aur@aur.archlinux.org/m17n-db-indic.git`
+ - Generate or update .SRCINFO with `makepkg --printsrcinfo > .SRCINFO`
+ - Push to the AUR repo. (Even a single invalid commit will cause rejection.)