summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHezekiah Michael2023-06-04 14:56:05 -0400
committerHezekiah Michael2023-06-04 14:56:05 -0400
commit179feb60289c4fcc8f0688298a49bb520836d6f9 (patch)
tree547a91b819a4000b936061ee861f87b20f34129d
parentb531a6bc78e32f38ed8842fc29d99512cff5ba71 (diff)
downloadaur-179feb60289c4fcc8f0688298a49bb520836d6f9.tar.gz
update to 0.0.4~20230213 prerelease, add license
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD27
3 files changed, 25 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 191f788568dc..76def46a9311 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
pkgbase = m4b-tool-bin
pkgdesc = A command line utility to merge, split and chapterize audiobook files such as mp3, ogg, flac, m4a or m4b
- pkgver = 0.4.2~20210603
+ pkgver = 0.4.2~20230213
pkgrel = 1
url = https://github.com/sandreas/m4b-tool
arch = x86_64
- license = MIT
+ license = custom:MIT
depends = ffmpeg
depends = libmp4v2
depends = php
- depends = php-intl
- depends = fdkaac
+ optdepends = fdkaac: to use fdkaac in conversions
optdepends = ffmpeg-libfdk_aac: to use fdkaac in conversions
+ optdepends = tone-bin
options = !strip
- source = m4b-tool.tar.gz::https://github.com/sandreas/m4b-tool/files/6598116/m4b-tool.tar.gz
- sha256sums = ae3b350ddc4b3037205a8594cd9255c406130fe264cf965f40357927acbc9925
+ source = m4b-tool.tar.gz::https://github.com/sandreas/m4b-tool/files/10728378/m4b-tool.tar.gz
+ source = https://raw.githubusercontent.com/sandreas/m4b-tool/03043298eb477d925c50ba81097b0cf43558738e/LICENSE
+ sha256sums = 181fb3e332849ea704ef860aaabaf9dcab2fdab298ffba99e66d31efa18b02f2
+ sha256sums = f4e10d52874360d5da10907ef1179e7064fbb1b1d51d1d548bb73d91afcfb65e
pkgname = m4b-tool-bin
diff --git a/.gitignore b/.gitignore
index 6aec17407bad..fe67616f70c8 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,4 @@
pkg
src
*.zst
+LICENSE
diff --git a/PKGBUILD b/PKGBUILD
index eb27fb83f0d6..d850e0a68123 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,24 @@
pkgdesc='A command line utility to merge, split and chapterize audiobook files such as mp3, ogg, flac, m4a or m4b'
pkgname=('m4b-tool-bin')
-pkgver=0.4.2~20210604
+pkgver=0.4.2~20230213
pkgrel=1
arch=('x86_64')
-license=('MIT')
+license=('custom:MIT')
url="https://github.com/sandreas/m4b-tool"
makedepends=()
-depends=('ffmpeg'
- 'libmp4v2'
- 'php'
- 'php-intl'
- 'fdkaac'
+depends=(
+ 'ffmpeg'
+ 'libmp4v2'
+ 'php'
)
-optdepends=('ffmpeg-libfdk_aac: to use fdkaac in conversions')
+optdepends=(
+ 'fdkaac: to use fdkaac in conversions'
+ 'ffmpeg-libfdk_aac: to use fdkaac in conversions'
+ 'tone-bin')
options=('!strip')
-source=("m4b-tool.tar.gz::https://github.com/sandreas/m4b-tool/files/6598116/m4b-tool.tar.gz")
+source=("m4b-tool.tar.gz::https://github.com/sandreas/m4b-tool/files/10728378/m4b-tool.tar.gz"
+ "https://raw.githubusercontent.com/sandreas/m4b-tool/03043298eb477d925c50ba81097b0cf43558738e/LICENSE")
pkgver() {
@@ -27,7 +30,9 @@ pkgver() {
package() {
cd ${srcdir}
- install -Dm 755 m4b-tool.phar "${pkgdir}/usr/local/bin/m4b-tool"
+ install -Dvm 755 m4b-tool.phar "${pkgdir}/usr/bin/m4b-tool"
+ install -Dvm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
}
-sha256sums=('ae3b350ddc4b3037205a8594cd9255c406130fe264cf965f40357927acbc9925')
+sha256sums=('181fb3e332849ea704ef860aaabaf9dcab2fdab298ffba99e66d31efa18b02f2'
+ 'f4e10d52874360d5da10907ef1179e7064fbb1b1d51d1d548bb73d91afcfb65e')